]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/commitdiff
always run module load test
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 17 Oct 2017 17:32:31 +0000 (20:32 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Tue, 17 Oct 2017 17:32:31 +0000 (20:32 +0300)
php-pecl-mongodb.spec

index e09a6777d6cdfe8451c8653ddf19479dd6908be5..c6c9cf17661b4d1c7292f21be95b80d38be0f44d 100644 (file)
@@ -68,8 +68,7 @@ phpize
 
 %{__make}
 
 
 %{__make}
 
-%if %{with tests}
-# simple module load test
+# simple module load test, always enabled
 %{__php} -n -q \
        -d extension_dir=modules \
        -d extension=%{php_extensiondir}/json.so \
 %{__php} -n -q \
        -d extension_dir=modules \
        -d extension=%{php_extensiondir}/json.so \
@@ -78,10 +77,18 @@ phpize
        -m > modules.log
 grep %{modname} modules.log
 
        -m > modules.log
 grep %{modname} modules.log
 
+%if %{with tests}
+cat <<'EOF' > run-tests.sh
+#!/bin/sh
 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
-%{__make} test \
+exec %{__make} test \
        PHP_EXECUTABLE=%{__php} \
        PHP_EXECUTABLE=%{__php} \
-       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="json"
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="json spl" \
+       RUN_TESTS_SETTINGS="-q $*"
+EOF
+chmod +x run-tests.sh
+
+./run-tests.sh
 %endif
 
 %install
 %endif
 
 %install
This page took 0.146994 seconds and 4 git commands to generate.