]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/commitdiff
add sasl bcond.
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 29 Oct 2017 15:35:23 +0000 (17:35 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Sun, 29 Oct 2017 15:35:23 +0000 (17:35 +0200)
building without sasl support doesn't fix crash
http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2017-October/025439.html

php-pecl-mongodb.spec

index a6c49a7858e84a5af1874e6c9a4aed21edfa1fa3..51add1bbc9b0f44f05abab3a6480c30161509d8d 100644 (file)
@@ -5,6 +5,7 @@
 #
 # Conditional build:
 %bcond_without tests           # build without tests
+%bcond_without sasl            # Include Cyrus SASL support
 
 %define                php_name        php%{?php_suffix}
 %define                modname mongodb
@@ -24,7 +25,7 @@ BuildRequires:        %{php_name}-devel >= 4:5.4.0
 BuildRequires: %{php_name}-json
 BuildRequires: %{php_name}-pcre
 BuildRequires: %{php_name}-spl
-BuildRequires: cyrus-sasl-devel
+%{?with_sasl:BuildRequires:    cyrus-sasl-devel}
 BuildRequires: libbson-devel >= 1.5.0
 BuildRequires: mongo-c-driver-devel >= 1.5.0
 BuildRequires: openssl-devel
@@ -65,7 +66,7 @@ phpize
 %configure \
        --with-libbson \
        --with-libmongoc \
-       --with-mongodb-sasl \
+       --with-mongodb-sasl=%{!?with_sasl:no}%{?with_sasl:yes} \
        --enable-mongodb
 
 %{__make}
This page took 0.055996 seconds and 4 git commands to generate.