]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/commitdiff
up to 1.5.2
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 24 Sep 2018 18:20:10 +0000 (21:20 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Mon, 24 Sep 2018 18:24:13 +0000 (21:24 +0300)
php-pecl-mongodb.spec
php-version.patch [deleted file]

index ac8b928db828a5e5246853d118a7c052b04a8d26..cda92ccd84587b8944ce27daeaa4de1b6b62516c 100644 (file)
 %define                modname mongodb
 Summary:       MongoDB driver for PHP
 Name:          %{php_name}-pecl-%{modname}
-Version:       1.4.2
-Release:       2
+Version:       1.5.2
+Release:       1
 License:       Apache v2.0
 Group:         Development/Languages/PHP
 Source0:       https://pecl.php.net/get/%{modname}-%{version}.tgz
-# Source0-md5: 28084c896be33df1ca268898646b7e32
-Patch0:                php-version.patch
+# Source0-md5: 3569a12839c9908a25dac15df1ae9d18
 Source1:       mongodb.ini
 URL:           https://pecl.php.net/package/mongodb
 BuildRequires: %{php_name}-cli
-BuildRequires: %{php_name}-devel >= 4:5.4.0
+BuildRequires: %{php_name}-devel >= 4:5.5.0
 BuildRequires: %{php_name}-json
 BuildRequires: %{php_name}-pcre
 BuildRequires: %{php_name}-spl
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel}
 %if %{without bundled}
-BuildRequires: libbson-devel >= 1.8.0
+BuildRequires: libbson-devel >= 1.11.0
 BuildRequires: mongo-c-driver-devel >= 1.9
 %endif
 BuildRequires: openssl-devel
@@ -52,7 +51,6 @@ MongoDB driver.
 %prep
 %setup -qc
 mv %{modname}-%{version}/* .
-%patch0 -p1
 
 %if %{without bundled}
 # Ensure we use system library
@@ -64,8 +62,12 @@ find \
 %endif
 
 %build
+get_version() {
+       local define="$1" filename="$2"
+       awk -vdefine="$define" '/#define/ && $2 == define {print $3}' "$filename" | xargs
+}
 # Sanity check, really often broken
-extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
+extver=$(get_version PHP_MONGODB_VERSION phongo_version.h)
 if test "x${extver}" != "x%{version}"; then
        : Error: Upstream extension version is ${extver}, expecting %{version}.
        exit 1
diff --git a/php-version.patch b/php-version.patch
deleted file mode 100644 (file)
index 35d87a0..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- php54-pecl-mongodb-1.4.2/config.m4~        2018-03-06 22:50:22.000000000 +0200
-+++ php54-pecl-mongodb-1.4.2/config.m4 2018-04-02 23:07:46.043110993 +0300
-@@ -86,8 +86,8 @@
-   PHP_MONGODB_FOUND_VERSION=`${PHP_CONFIG} --version`
-   PHP_MONGODB_FOUND_VERNUM=`echo "${PHP_MONGODB_FOUND_VERSION}" | $AWK 'BEGIN { FS = "."; } { printf "%d", ([$]1 * 100 + [$]2) * 100 + [$]3;}'`
-   AC_MSG_RESULT($PHP_MONGODB_FOUND_VERSION)
--  if test "$PHP_MONGODB_FOUND_VERNUM" -lt "50500"; then
--    AC_MSG_ERROR([not supported. Need a PHP version >= 5.5.0 (found $PHP_MONGODB_FOUND_VERSION)])
-+  if test "$PHP_MONGODB_FOUND_VERNUM" -lt "50400"; then
-+    AC_MSG_ERROR([not supported. Need a PHP version >= 5.4.0 (found $PHP_MONGODB_FOUND_VERSION)])
-   fi
-   PHP_ARG_ENABLE([developer-flags],
This page took 0.086147 seconds and 4 git commands to generate.