]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/commitdiff
re-order after openssl module auto/th/php-pecl-mongodb-1.4.2-1
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 2 Apr 2018 19:55:39 +0000 (22:55 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Mon, 2 Apr 2018 19:55:39 +0000 (22:55 +0300)
workaround for openssl 1.0.2 unidentified crash
https://github.com/mongodb/mongo-php-driver/issues/789

should be not needed with openssl 1.1.0

php-pecl-mongodb.spec

index 45933bb07e02aae41d74cb39a1693f605cae6312..76d5aa77afae152492e6a090df0f69fb408b8401 100644 (file)
@@ -6,7 +6,7 @@
 # Conditional build:
 %bcond_without tests           # build without tests
 %bcond_with    sasl            # Include Cyrus SASL support (for bundled only)
-%bcond_with    ssl             # Enable TLS connections and SCRAM-SHA-1 authentication (for bundled only)
+%bcond_without ssl             # Enable TLS connections and SCRAM-SHA-1 authentication (for bundled only)
 %bcond_with    bundled         # Use bundled libbson, libmongoc
 
 %define                php_name        php%{?php_suffix}
@@ -110,12 +110,12 @@ rm -rf $RPM_BUILD_ROOT
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
-cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/openssl_%{modname}.ini
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/*%{modname}.ini
 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.061463 seconds and 4 git commands to generate.