]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/blob - php-pecl-mongodb.spec
e09a6777d6cdfe8451c8653ddf19479dd6908be5
[packages/php-pecl-mongodb.git] / php-pecl-mongodb.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname mongodb
7 Summary:        MongoDB driver for PHP
8 Name:           %{php_name}-pecl-%{modname}
9 Version:        1.2.11
10 Release:        1
11 License:        Apache v2.0
12 Group:          Development/Languages/PHP
13 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
14 # Source0-md5:  c3b36a24b7e47e3b4148cd9bc4d163b2
15 URL:            https://pecl.php.net/package/mongodb
16 BuildRequires:  %{php_name}-devel >= 4:5.4.0
17 BuildRequires:  rpmbuild(macros) >= 1.666
18 %if %{with tests}
19 BuildRequires:  %{php_name}-json
20 BuildRequires:  %{php_name}-spl
21 %endif
22 BuildRequires:  cyrus-sasl-devel
23 BuildRequires:  libbson-devel >= 1.5
24 BuildRequires:  mongo-c-driver-devel >= 1.5
25 BuildRequires:  openssl-devel
26 Requires:       %{php_name}-json
27 %{?requires_php_extension}
28 Provides:       php(%{modname}) = %{version}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The purpose of this driver is to provide exceptionally thin glue
33 between MongoDB and PHP, implementing only fundemental and
34 performance-critical components necessary to build a fully-functional
35 MongoDB driver.
36
37 %prep
38 %setup -qc
39 mv %{modname}-%{version}/* .
40
41 # Create configuration file
42 cat << 'EOF' > %{modname}.ini
43 ; Enable %{summary} extension module
44 extension=%{modname}.so
45
46 ; Configuration
47 ;mongodb.debug=''
48 EOF
49
50 %build
51 # Sanity check, really often broken
52 extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
53 if test "x${extver}" != "x%{version}"; then
54         : Error: Upstream extension version is ${extver}, expecting %{version}.
55         exit 1
56 fi
57
58 phpize
59 # Ensure we use system library
60 # Need to be removed only after phpize because of m4_include
61 %{__rm} -r src/libbson
62 %{__rm} -r src/libmongoc
63
64 %configure \
65         --with-libbson \
66         --with-libmongoc \
67         --enable-mongodb
68
69 %{__make}
70
71 %if %{with tests}
72 # simple module load test
73 %{__php} -n -q \
74         -d extension_dir=modules \
75         -d extension=%{php_extensiondir}/json.so \
76         -d extension=%{php_extensiondir}/spl.so \
77         -d extension=%{modname}.so \
78         -m > modules.log
79 grep %{modname} modules.log
80
81 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
82 %{__make} test \
83         PHP_EXECUTABLE=%{__php} \
84         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="json"
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} install \
90         EXTENSION_DIR=%{php_extensiondir} \
91         INSTALL_ROOT=$RPM_BUILD_ROOT
92
93 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
94 cp -p %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
102 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.06282 seconds and 2 git commands to generate.