]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/blob - php-pecl-mongodb.spec
Up to 1.6.1, requires php 5.6
[packages/php-pecl-mongodb.git] / php-pecl-mongodb.spec
1 # TODO
2 # - ix86/x32 (php -m) prints::
3 #   src/mongoc/mongoc-handshake.c:478 _append_and_truncate(): precondition failed: space_for_suffix >= 0
4 #   Aborted
5 #
6 # Conditional build:
7 %bcond_without  tests           # build without tests
8 %bcond_with     sasl            # Include Cyrus SASL support (for bundled only)
9 %bcond_without  ssl             # Enable TLS connections and SCRAM-SHA-1 authentication (for bundled only)
10 %bcond_with     bundled         # Use bundled libmongoc
11
12 %define         php_name        php%{?php_suffix}
13 %define         modname mongodb
14 Summary:        MongoDB driver for PHP
15 Name:           %{php_name}-pecl-%{modname}
16 Version:        1.6.1
17 Release:        1
18 License:        Apache v2.0
19 Group:          Development/Languages/PHP
20 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
21 # Source0-md5:  123e48da2f674de6d567b0bebbe049ac
22 Source1:        mongodb.ini
23 URL:            https://pecl.php.net/package/mongodb
24 BuildRequires:  %{php_name}-cli
25 BuildRequires:  %{php_name}-devel >= 4:5.6.0
26 BuildRequires:  %{php_name}-json
27 BuildRequires:  %{php_name}-pcre
28 BuildRequires:  %{php_name}-spl
29 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
30 %if %{without bundled}
31 BuildRequires:  libbson-devel >= 1.15.2
32 BuildRequires:  mongo-c-driver-devel >= 1.15.2
33 %endif
34 BuildRequires:  openssl-devel
35 BuildRequires:  rpmbuild(macros) >= 1.666
36 Requires:       %{php_name}-json
37 Requires:       mongo-c-driver-libs >= 1.15.2
38 Requires:       %{php_name}-pcre
39 Requires:       %{php_name}-spl
40 %{?requires_php_extension}
41 Provides:       php(%{modname}) = %{version}
42 ExcludeArch:    %{ix86} x32
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 The purpose of this driver is to provide exceptionally thin glue
47 between MongoDB and PHP, implementing only fundemental and
48 performance-critical components necessary to build a fully-functional
49 MongoDB driver.
50
51 %prep
52 %setup -qc
53 mv %{modname}-%{version}/* .
54
55 %if %{without bundled}
56 # Ensure we use system library
57 # remove only C sources, m4 resources needed for phpize via m4_include
58 find \
59         src/libmongoc \
60         -name '*.[ch]' -delete
61 %endif
62
63 xfail() {
64         local t=$1
65         test -f $t
66         cat >> $t <<-EOF
67
68         --XFAIL--
69         Skip
70         EOF
71 }
72
73 # failed tests. investigate later
74 while read line; do
75         t=${line##*\[}; t=${t%\]}
76         xfail $t
77 done << 'EOF'
78 MongoDB\BSON\Javascript::__set_state() [tests/bson/bson-javascript-set_state-001.phpt]
79 MongoDB\Driver\ReadPreference: var_export() [tests/readPreference/readpreference-var_export-001.phpt]
80 MongoDB\Driver\Session with wrong defaultTransactionOptions [tests/session/session_error-001.phpt]
81 EOF
82
83 %build
84 get_version() {
85         local define="$1" filename="$2"
86         awk -vdefine="$define" '/#define/ && $2 == define {print $3}' "$filename" | xargs
87 }
88 # Sanity check, really often broken
89 extver=$(get_version PHP_MONGODB_VERSION phongo_version.h)
90 if test "x${extver}" != "x%{version}"; then
91         : Error: Upstream extension version is ${extver}, expecting %{version}.
92         exit 1
93 fi
94
95 phpize
96
97 %configure \
98         --with-libbson=%{?with_bundled:no}%{!?with_bundled:yes} \
99         --with-libmongoc=%{?with_bundled:no}%{!?with_bundled:yes} \
100         --with-mongodb-ssl=%{!?with_ssl:no}%{?with_ssl:openssl} \
101         --with-mongodb-sasl=%{!?with_sasl:no}%{?with_sasl:yes} \
102         --enable-mongodb
103
104 %{__make}
105
106 # simple module load test, always enabled
107 %{__php} -n -q \
108         -d extension_dir=modules \
109 %if "%php_major_version.%php_minor_version" < "7.4"
110         -d extension=%{php_extensiondir}/pcre.so \
111         -d extension=%{php_extensiondir}/spl.so \
112 %endif
113         -d extension=%{php_extensiondir}/json.so \
114         -d extension=%{modname}.so \
115         -m > modules.log
116 grep %{modname} modules.log
117
118 %if %{with tests}
119 cat <<'EOF' > run-tests.sh
120 #!/bin/sh
121 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
122 exec %{__make} test \
123         PHP_EXECUTABLE=%{__php} \
124 %if "%php_major_version.%php_minor_version" < "7.4"
125         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl json" \
126 %else
127         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="json" \
128 %endif
129         RUN_TESTS_SETTINGS="-q $*"
130 EOF
131 chmod +x run-tests.sh
132
133 ./run-tests.sh
134 %endif
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 %{__make} install \
139         EXTENSION_DIR=%{php_extensiondir} \
140         INSTALL_ROOT=$RPM_BUILD_ROOT
141
142 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
143 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files
149 %defattr(644,root,root,755)
150 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
151 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.06498 seconds and 3 git commands to generate.