]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/blob - php-pecl-mongodb.spec
it still compiles with php 5.4, so allow building it
[packages/php-pecl-mongodb.git] / php-pecl-mongodb.spec
1 # TODO
2 # - ix86/x32 (php -m) prints::
3 #   src/mongoc/mongoc-handshake.c:478 _append_and_truncate(): precondition failed: space_for_suffix >= 0
4 #   Aborted
5 #
6 # Conditional build:
7 %bcond_without  tests           # build without tests
8 %bcond_with     sasl            # Include Cyrus SASL support (for bundled only)
9 %bcond_without  ssl             # Enable TLS connections and SCRAM-SHA-1 authentication (for bundled only)
10 %bcond_with     bundled         # Use bundled libbson, libmongoc
11
12 %define         php_name        php%{?php_suffix}
13 %define         modname mongodb
14 Summary:        MongoDB driver for PHP
15 Name:           %{php_name}-pecl-%{modname}
16 Version:        1.4.2
17 Release:        1
18 License:        Apache v2.0
19 Group:          Development/Languages/PHP
20 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
21 # Source0-md5:  28084c896be33df1ca268898646b7e32
22 Patch0:         php-version.patch
23 Source1:        mongodb.ini
24 URL:            https://pecl.php.net/package/mongodb
25 BuildRequires:  %{php_name}-cli
26 BuildRequires:  %{php_name}-devel >= 4:5.4.0
27 BuildRequires:  %{php_name}-json
28 BuildRequires:  %{php_name}-pcre
29 BuildRequires:  %{php_name}-spl
30 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
31 %if %{without bundled}
32 BuildRequires:  libbson-devel >= 1.8.0
33 BuildRequires:  mongo-c-driver-devel >= 1.9
34 %endif
35 BuildRequires:  openssl-devel
36 BuildRequires:  rpmbuild(macros) >= 1.666
37 Requires:       %{php_name}-json
38 Requires:       %{php_name}-pcre
39 Requires:       %{php_name}-spl
40 %{?requires_php_extension}
41 Provides:       php(%{modname}) = %{version}
42 ExcludeArch:    %{ix86} x32
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 The purpose of this driver is to provide exceptionally thin glue
47 between MongoDB and PHP, implementing only fundemental and
48 performance-critical components necessary to build a fully-functional
49 MongoDB driver.
50
51 %prep
52 %setup -qc
53 mv %{modname}-%{version}/* .
54 %patch0 -p1
55
56 %if %{without bundled}
57 # Ensure we use system library
58 # remove only C sources, m4 resources needed for phpize via m4_include
59 find \
60         src/libbson \
61         src/libmongoc \
62         -name '*.[ch]' | xargs %{__rm} -v
63 %endif
64
65 %build
66 # Sanity check, really often broken
67 extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
68 if test "x${extver}" != "x%{version}"; then
69         : Error: Upstream extension version is ${extver}, expecting %{version}.
70         exit 1
71 fi
72
73 phpize
74
75 %configure \
76         --with-libbson=%{?with_bundled:no}%{!?with_bundled:yes} \
77         --with-libmongoc=%{?with_bundled:no}%{!?with_bundled:yes} \
78         --with-mongodb-ssl=%{!?with_ssl:no}%{?with_ssl:openssl} \
79         --with-mongodb-sasl=%{!?with_sasl:no}%{?with_sasl:yes} \
80         --enable-mongodb
81
82 %{__make}
83
84 # simple module load test, always enabled
85 %{__php} -n -q \
86         -d extension_dir=modules \
87         -d extension=%{php_extensiondir}/pcre.so \
88         -d extension=%{php_extensiondir}/spl.so \
89         -d extension=%{php_extensiondir}/json.so \
90         -d extension=%{modname}.so \
91         -m > modules.log
92 grep %{modname} modules.log
93
94 %if %{with tests}
95 cat <<'EOF' > run-tests.sh
96 #!/bin/sh
97 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
98 exec %{__make} test \
99         PHP_EXECUTABLE=%{__php} \
100         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl json" \
101         RUN_TESTS_SETTINGS="-q $*"
102 EOF
103 chmod +x run-tests.sh
104
105 ./run-tests.sh
106 %endif
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 %{__make} install \
111         EXTENSION_DIR=%{php_extensiondir} \
112         INSTALL_ROOT=$RPM_BUILD_ROOT
113
114 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
115 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/openssl_%{modname}.ini
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/*%{modname}.ini
123 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.0797 seconds and 3 git commands to generate.