]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/blob - php-pecl-mongodb.spec
77b40b4afff8a5e22f8b2a29a2acbf6ab0be20bf
[packages/php-pecl-mongodb.git] / php-pecl-mongodb.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname mongodb
7 Summary:        MongoDB driver for PHP
8 Name:           %{php_name}-pecl-%{modname}
9 Version:        1.2.11
10 Release:        1
11 License:        Apache v2.0
12 Group:          Development/Languages/PHP
13 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
14 # Source0-md5:  c3b36a24b7e47e3b4148cd9bc4d163b2
15 Source1:        mongodb.ini
16 Patch0:         tests.patch
17 URL:            https://pecl.php.net/package/mongodb
18 BuildRequires:  %{php_name}-devel >= 4:5.4.0
19 BuildRequires:  rpmbuild(macros) >= 1.666
20 %if %{with tests}
21 BuildRequires:  %{php_name}-json
22 BuildRequires:  %{php_name}-spl
23 %endif
24 BuildRequires:  cyrus-sasl-devel
25 BuildRequires:  libbson-devel >= 1.5
26 BuildRequires:  mongo-c-driver-devel >= 1.5
27 BuildRequires:  openssl-devel
28 Requires:       %{php_name}-json
29 %{?requires_php_extension}
30 Provides:       php(%{modname}) = %{version}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The purpose of this driver is to provide exceptionally thin glue
35 between MongoDB and PHP, implementing only fundemental and
36 performance-critical components necessary to build a fully-functional
37 MongoDB driver.
38
39 %prep
40 %setup -qc
41 mv %{modname}-%{version}/* .
42 %patch0 -p1
43
44 %build
45 # Sanity check, really often broken
46 extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
47 if test "x${extver}" != "x%{version}"; then
48         : Error: Upstream extension version is ${extver}, expecting %{version}.
49         exit 1
50 fi
51
52 phpize
53 # Ensure we use system library
54 # Need to be removed only after phpize because of m4_include
55 %{__rm} -r src/libbson
56 %{__rm} -r src/libmongoc
57
58 %configure \
59         --with-libbson \
60         --with-libmongoc \
61         --enable-mongodb
62
63 %{__make}
64
65 # simple module load test, always enabled
66 %{__php} -n -q \
67         -d extension_dir=modules \
68         -d extension=%{php_extensiondir}/json.so \
69         -d extension=%{php_extensiondir}/spl.so \
70         -d extension=%{modname}.so \
71         -m > modules.log
72 grep %{modname} modules.log
73
74 %if %{with tests}
75 cat <<'EOF' > run-tests.sh
76 #!/bin/sh
77 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
78 exec %{__make} test \
79         PHP_EXECUTABLE=%{__php} \
80         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="json spl" \
81         RUN_TESTS_SETTINGS="-q $*"
82 EOF
83 chmod +x run-tests.sh
84
85 ./run-tests.sh
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %{__make} install \
91         EXTENSION_DIR=%{php_extensiondir} \
92         INSTALL_ROOT=$RPM_BUILD_ROOT
93
94 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
95 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
103 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.052618 seconds and 2 git commands to generate.