]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/blame - php-pecl-mongodb.spec
it still compiles with php 5.4, so allow building it
[packages/php-pecl-mongodb.git] / php-pecl-mongodb.spec
CommitLineData
72c237bb
ER
1# TODO
2# - ix86/x32 (php -m) prints::
3# src/mongoc/mongoc-handshake.c:478 _append_and_truncate(): precondition failed: space_for_suffix >= 0
4# Aborted
e6a2fe32
ER
5#
6# Conditional build:
7%bcond_without tests # build without tests
3cfe18c3 8%bcond_with sasl # Include Cyrus SASL support (for bundled only)
3bff6cd8 9%bcond_without ssl # Enable TLS connections and SCRAM-SHA-1 authentication (for bundled only)
3cfe18c3 10%bcond_with bundled # Use bundled libbson, libmongoc
e6a2fe32
ER
11
12%define php_name php%{?php_suffix}
13%define modname mongodb
14Summary: MongoDB driver for PHP
78f25fe6 15Name: %{php_name}-pecl-%{modname}
3cfe18c3 16Version: 1.4.2
78f25fe6 17Release: 1
e6a2fe32
ER
18License: Apache v2.0
19Group: Development/Languages/PHP
78f25fe6 20Source0: https://pecl.php.net/get/%{modname}-%{version}.tgz
3cfe18c3 21# Source0-md5: 28084c896be33df1ca268898646b7e32
ee0b9bb4 22Patch0: php-version.patch
29b44cd3 23Source1: mongodb.ini
e6a2fe32 24URL: https://pecl.php.net/package/mongodb
2782ab30 25BuildRequires: %{php_name}-cli
a88e3999 26BuildRequires: %{php_name}-devel >= 4:5.4.0
e6a2fe32 27BuildRequires: %{php_name}-json
7ac97c34 28BuildRequires: %{php_name}-pcre
4b7a708c 29BuildRequires: %{php_name}-spl
bc94cadc 30%{?with_sasl:BuildRequires: cyrus-sasl-devel}
3cfe18c3 31%if %{without bundled}
463d8c74 32BuildRequires: libbson-devel >= 1.8.0
3cfe18c3
ER
33BuildRequires: mongo-c-driver-devel >= 1.9
34%endif
e6a2fe32 35BuildRequires: openssl-devel
a88e3999 36BuildRequires: rpmbuild(macros) >= 1.666
e6a2fe32 37Requires: %{php_name}-json
9d61e514
ER
38Requires: %{php_name}-pcre
39Requires: %{php_name}-spl
e6a2fe32
ER
40%{?requires_php_extension}
41Provides: php(%{modname}) = %{version}
72c237bb 42ExcludeArch: %{ix86} x32
e6a2fe32
ER
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46The purpose of this driver is to provide exceptionally thin glue
47between MongoDB and PHP, implementing only fundemental and
48performance-critical components necessary to build a fully-functional
49MongoDB driver.
50
51%prep
52%setup -qc
53mv %{modname}-%{version}/* .
ee0b9bb4 54%patch0 -p1
e6a2fe32 55
3cfe18c3 56%if %{without bundled}
8cb30902
ER
57# Ensure we use system library
58# remove only C sources, m4 resources needed for phpize via m4_include
59find \
60 src/libbson \
61 src/libmongoc \
62 -name '*.[ch]' | xargs %{__rm} -v
3cfe18c3 63%endif
8cb30902 64
e6a2fe32
ER
65%build
66# Sanity check, really often broken
67extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
68if test "x${extver}" != "x%{version}"; then
69 : Error: Upstream extension version is ${extver}, expecting %{version}.
70 exit 1
71fi
72
73phpize
e6a2fe32
ER
74
75%configure \
3cfe18c3
ER
76 --with-libbson=%{?with_bundled:no}%{!?with_bundled:yes} \
77 --with-libmongoc=%{?with_bundled:no}%{!?with_bundled:yes} \
78 --with-mongodb-ssl=%{!?with_ssl:no}%{?with_ssl:openssl} \
bc94cadc 79 --with-mongodb-sasl=%{!?with_sasl:no}%{?with_sasl:yes} \
e6a2fe32
ER
80 --enable-mongodb
81
82%{__make}
83
c485d9ea 84# simple module load test, always enabled
e6a2fe32
ER
85%{__php} -n -q \
86 -d extension_dir=modules \
7ac97c34 87 -d extension=%{php_extensiondir}/pcre.so \
4b7a708c 88 -d extension=%{php_extensiondir}/spl.so \
7ac97c34 89 -d extension=%{php_extensiondir}/json.so \
e6a2fe32
ER
90 -d extension=%{modname}.so \
91 -m > modules.log
92grep %{modname} modules.log
93
c485d9ea
ER
94%if %{with tests}
95cat <<'EOF' > run-tests.sh
96#!/bin/sh
e6a2fe32 97export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
c485d9ea 98exec %{__make} test \
e6a2fe32 99 PHP_EXECUTABLE=%{__php} \
7ac97c34 100 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl json" \
c485d9ea
ER
101 RUN_TESTS_SETTINGS="-q $*"
102EOF
103chmod +x run-tests.sh
104
105./run-tests.sh
e6a2fe32
ER
106%endif
107
108%install
109rm -rf $RPM_BUILD_ROOT
110%{__make} install \
111 EXTENSION_DIR=%{php_extensiondir} \
112 INSTALL_ROOT=$RPM_BUILD_ROOT
113
78f25fe6 114install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
3bff6cd8 115cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/openssl_%{modname}.ini
e6a2fe32
ER
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(644,root,root,755)
3bff6cd8 122%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/*%{modname}.ini
e6a2fe32 123%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.065085 seconds and 4 git commands to generate.