]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/blame - php-pecl-mongodb.spec
Fix test for php 7.4
[packages/php-pecl-mongodb.git] / php-pecl-mongodb.spec
CommitLineData
72c237bb
ER
1# TODO
2# - ix86/x32 (php -m) prints::
3# src/mongoc/mongoc-handshake.c:478 _append_and_truncate(): precondition failed: space_for_suffix >= 0
4# Aborted
e6a2fe32
ER
5#
6# Conditional build:
7%bcond_without tests # build without tests
3cfe18c3 8%bcond_with sasl # Include Cyrus SASL support (for bundled only)
3bff6cd8 9%bcond_without ssl # Enable TLS connections and SCRAM-SHA-1 authentication (for bundled only)
efb59f9a 10%bcond_with bundled # Use bundled libmongoc
e6a2fe32
ER
11
12%define php_name php%{?php_suffix}
13%define modname mongodb
14Summary: MongoDB driver for PHP
78f25fe6 15Name: %{php_name}-pecl-%{modname}
b2624ac3 16Version: 1.5.5
512f9152 17Release: 1
e6a2fe32
ER
18License: Apache v2.0
19Group: Development/Languages/PHP
78f25fe6 20Source0: https://pecl.php.net/get/%{modname}-%{version}.tgz
b2624ac3 21# Source0-md5: 0839657e7fb4f5ea8113ef140835674a
29b44cd3 22Source1: mongodb.ini
e6a2fe32 23URL: https://pecl.php.net/package/mongodb
2782ab30 24BuildRequires: %{php_name}-cli
512f9152 25BuildRequires: %{php_name}-devel >= 4:5.5.0
e6a2fe32 26BuildRequires: %{php_name}-json
7ac97c34 27BuildRequires: %{php_name}-pcre
4b7a708c 28BuildRequires: %{php_name}-spl
bc94cadc 29%{?with_sasl:BuildRequires: cyrus-sasl-devel}
3cfe18c3 30%if %{without bundled}
512f9152 31BuildRequires: libbson-devel >= 1.11.0
3cfe18c3
ER
32BuildRequires: mongo-c-driver-devel >= 1.9
33%endif
e6a2fe32 34BuildRequires: openssl-devel
a88e3999 35BuildRequires: rpmbuild(macros) >= 1.666
e6a2fe32 36Requires: %{php_name}-json
b3161ed1 37Requires: mongo-c-driver-libs >= 1.9.3-2
9d61e514
ER
38Requires: %{php_name}-pcre
39Requires: %{php_name}-spl
e6a2fe32
ER
40%{?requires_php_extension}
41Provides: php(%{modname}) = %{version}
72c237bb 42ExcludeArch: %{ix86} x32
e6a2fe32
ER
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46The purpose of this driver is to provide exceptionally thin glue
47between MongoDB and PHP, implementing only fundemental and
48performance-critical components necessary to build a fully-functional
49MongoDB driver.
50
51%prep
52%setup -qc
53mv %{modname}-%{version}/* .
54
3cfe18c3 55%if %{without bundled}
8cb30902
ER
56# Ensure we use system library
57# remove only C sources, m4 resources needed for phpize via m4_include
58find \
8cb30902 59 src/libmongoc \
efb59f9a 60 -name '*.[ch]' -delete
3cfe18c3 61%endif
8cb30902 62
279c36ad
ER
63xfail() {
64 local t=$1
65 test -f $t
66 cat >> $t <<-EOF
67
68 --XFAIL--
69 Skip
70 EOF
71}
72
73# failed tests. investigate later
74while read line; do
75 t=${line##*\[}; t=${t%\]}
76 xfail $t
77done << 'EOF'
78MongoDB\BSON\Javascript::__set_state() [tests/bson/bson-javascript-set_state-001.phpt]
279c36ad
ER
79MongoDB\Driver\ReadPreference: var_export() [tests/readPreference/readpreference-var_export-001.phpt]
80MongoDB\Driver\Session with wrong defaultTransactionOptions [tests/session/session_error-001.phpt]
81EOF
82
e6a2fe32 83%build
512f9152
ER
84get_version() {
85 local define="$1" filename="$2"
86 awk -vdefine="$define" '/#define/ && $2 == define {print $3}' "$filename" | xargs
87}
e6a2fe32 88# Sanity check, really often broken
512f9152 89extver=$(get_version PHP_MONGODB_VERSION phongo_version.h)
e6a2fe32
ER
90if test "x${extver}" != "x%{version}"; then
91 : Error: Upstream extension version is ${extver}, expecting %{version}.
92 exit 1
93fi
94
95phpize
e6a2fe32
ER
96
97%configure \
3cfe18c3
ER
98 --with-libbson=%{?with_bundled:no}%{!?with_bundled:yes} \
99 --with-libmongoc=%{?with_bundled:no}%{!?with_bundled:yes} \
100 --with-mongodb-ssl=%{!?with_ssl:no}%{?with_ssl:openssl} \
bc94cadc 101 --with-mongodb-sasl=%{!?with_sasl:no}%{?with_sasl:yes} \
e6a2fe32
ER
102 --enable-mongodb
103
104%{__make}
105
c485d9ea 106# simple module load test, always enabled
e6a2fe32
ER
107%{__php} -n -q \
108 -d extension_dir=modules \
e6527bb6 109%if "%php_major_version.%php_minor_version" < "7.4"
7ac97c34 110 -d extension=%{php_extensiondir}/pcre.so \
4b7a708c 111 -d extension=%{php_extensiondir}/spl.so \
e6527bb6 112%endif
7ac97c34 113 -d extension=%{php_extensiondir}/json.so \
e6a2fe32
ER
114 -d extension=%{modname}.so \
115 -m > modules.log
116grep %{modname} modules.log
117
c485d9ea
ER
118%if %{with tests}
119cat <<'EOF' > run-tests.sh
120#!/bin/sh
e6a2fe32 121export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
c485d9ea 122exec %{__make} test \
e6a2fe32 123 PHP_EXECUTABLE=%{__php} \
e6527bb6 124%if "%php_major_version.%php_minor_version" < "7.4"
7ac97c34 125 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl json" \
e6527bb6
ER
126%else
127 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="json" \
128%endif
c485d9ea
ER
129 RUN_TESTS_SETTINGS="-q $*"
130EOF
131chmod +x run-tests.sh
132
133./run-tests.sh
e6a2fe32
ER
134%endif
135
136%install
137rm -rf $RPM_BUILD_ROOT
138%{__make} install \
139 EXTENSION_DIR=%{php_extensiondir} \
140 INSTALL_ROOT=$RPM_BUILD_ROOT
141
78f25fe6 142install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
b3161ed1 143cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
e6a2fe32
ER
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%files
149%defattr(644,root,root,755)
b3161ed1 150%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
e6a2fe32 151%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.075919 seconds and 4 git commands to generate.