]> git.pld-linux.org Git - packages/php-pecl-memcache.git/commitdiff
run tests with memcached
authorElan Ruusamäe <glen@delfi.ee>
Wed, 23 Nov 2016 02:29:03 +0000 (04:29 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 23 Nov 2016 02:29:03 +0000 (04:29 +0200)
php-pecl-memcache.spec

index 34470698fb22e4e380a0107deda6d2020d8e5368..1401601266c6d7feb087e0796e2e60e0b547e965 100644 (file)
@@ -33,6 +33,7 @@ BuildRequires:        %{php_name}-cli
 BuildRequires: %{php_name}-pcre
 BuildRequires: %{php_name}-session
 BuildRequires: %{php_name}-spl
+BuildRequires: memcached
 %endif
 %{?requires_php_extension}
 Requires:      %{php_name}-session
@@ -92,6 +93,9 @@ mv pecl-%{modname}-*/{.??*,*} .
 %patch0 -p1
 %patch1 -p1
 
+# locks up on carme, likely due udp very long timeout
+rm tests/039.phpt
+
 %build
 packagexml2cl package.xml > ChangeLog
 phpize
@@ -120,6 +124,10 @@ exec %{__make} test \
 EOF
 chmod +x run-tests.sh
 
+# Launch the Memcached service and stop it on exit
+%{_sbindir}/memcached -p 11211 -U 11211 -d -P $PWD/memcached.pid
+trap 'kill $(cat memcached.pid)' EXIT INT
+
 ./run-tests.sh
 %endif
 
This page took 0.074304 seconds and 4 git commands to generate.