]> git.pld-linux.org Git - packages/php-pecl-memcache.git/commitdiff
mark tests properly skipped
authorElan Ruusamäe <glen@delfi.ee>
Wed, 23 Nov 2016 02:02:12 +0000 (04:02 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 23 Nov 2016 02:02:12 +0000 (04:02 +0200)
https://github.com/websupport-sk/pecl-memcache/pull/16

php-pecl-memcache.spec
tests.patch [new file with mode: 0644]

index e2f6502f1c4188c2c87e4bd7349f1d4dfc2b7f9f..9d8dcf423ee82dfad0931bc30fe3ee0c93f8f361 100644 (file)
@@ -21,6 +21,7 @@ Source2:      %{modname}-apache.conf
 Source3:       %{modname}-lighttpd.conf
 Source4:       config.php
 Patch0:                %{modname}-webapp.patch
 Source3:       %{modname}-lighttpd.conf
 Source4:       config.php
 Patch0:                %{modname}-webapp.patch
+Patch1:                tests.patch
 URL:           http://pecl.php.net/package/memcache/
 BuildRequires: %{php_name}-devel >= 3:5.0.0
 BuildRequires: %{php_name}-xml
 URL:           http://pecl.php.net/package/memcache/
 BuildRequires: %{php_name}-devel >= 3:5.0.0
 BuildRequires: %{php_name}-xml
@@ -88,6 +89,7 @@ memcache.
 %setup -qc
 mv pecl-%{modname}-*/{.??*,*} .
 %patch0 -p1
 %setup -qc
 mv pecl-%{modname}-*/{.??*,*} .
 %patch0 -p1
+%patch1 -p1
 
 %build
 packagexml2cl package.xml > ChangeLog
 
 %build
 packagexml2cl package.xml > ChangeLog
diff --git a/tests.patch b/tests.patch
new file mode 100644 (file)
index 0000000..3976663
--- /dev/null
@@ -0,0 +1,20 @@
+
+move connect to proper section to make SKIP work
+
+https://github.com/websupport-sk/pecl-memcache/pull/16
+
+--- php70-pecl-memcache-3.0.9/tests/pecl16442.phpt~    2016-11-23 03:56:10.000000000 +0200
++++ php70-pecl-memcache-3.0.9/tests/pecl16442.phpt     2016-11-23 03:57:20.017464335 +0200
+@@ -1,10 +1,10 @@
+ --TEST--
+ PECL bug #16442 (memcache_set fail with integer value)
++--SKIPIF--
++<?php include 'connect.inc'; ?>
+ --FILE--
+ <?php
+-include 'connect.inc';
+-
+ $memcache_obj = memcache_connect('localhost', 11211);
+ memcache_set($memcache_obj, 'test123112', 1, MEMCACHE_COMPRESSED, 30);
+ $ret = memcache_get($memcache_obj, 'test123112');
This page took 0.046561 seconds and 4 git commands to generate.