]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blob - php-pecl-memcache.spec
- updated to 2.2.1
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
1 %define         _modname        memcache
2 %define         _status         stable
3 Summary:        %{_modname} - a memcached extension
4 Summary(pl.UTF-8):      %{_modname} - rozszerzenie memcached
5 Name:           php-pecl-%{_modname}
6 Version:        2.2.1
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  c05cc08a0e0c989236e4dc8b8920f8bd
12 URL:            http://pecl.php.net/package/memcache/
13 BuildRequires:  php-devel >= 3:5.0.0
14 BuildRequires:  rpmbuild(macros) >= 1.344
15 %{?requires_php_extension}
16 Requires:       php-common >= 4:5.0.4
17 Requires:       php(zlib)
18 #Sugests:       memcached
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Memcached is a caching daemon designed especially for dynamic web
24 applications to decrease database load by storing objects in memory.
25
26 This extension allows you to work with memcached through handy OO and
27 procedural interfaces.
28
29 In PECL status of this extension is: %{_status}.
30
31 %description -l pl.UTF-8
32 Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
33 daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
34 przez przechowywanie w pamięci obiektów.
35
36 To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
37 zorientowanego obiektowo (oraz przez procedury) interfejsu.
38
39 To rozszerzenie ma w PECL status: %{_status}.
40
41 %prep
42 %setup -q -c
43
44 %build
45 cd %{_modname}-%{version}
46 phpize
47 %configure \
48         --with-zlib-dir=/usr
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
54
55 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
56 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
57 ; Enable %{_modname} extension module
58 extension=%{_modname}.so
59 ;memcache.allow_failover=1
60 ;memcache.chunk_size=8192
61 ;memcache.default_port=11211
62 EOF
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %php_webserver_restart
69
70 %postun
71 if [ "$1" = 0 ]; then
72         %php_webserver_restart
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc %{_modname}-%{version}/{CREDITS,README}
78 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
79 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.077742 seconds and 4 git commands to generate.