]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blame - php-pecl-memcache.spec
run tests with memcached
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
CommitLineData
8dfd8797
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
3917ea3d 5%define php_name php%{?php_suffix}
a9222c27 6%define modname memcache
afdaa3d2 7%define php_min_version 5.0.0
3917ea3d 8%include /usr/lib/rpm/macros.php
a9222c27
ER
9Summary: %{modname} - a memcached extension
10Summary(pl.UTF-8): %{modname} - rozszerzenie memcached
3917ea3d 11Name: %{php_name}-pecl-%{modname}
10d2ed2a
ER
12Version: 3.0.9
13Release: 1
d7d5fbe6 14License: PHP 3.01
15f9ce79 15Group: Development/Languages/PHP
10d2ed2a
ER
16#Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
17Source0: https://github.com/websupport-sk/pecl-memcache/archive/NON_BLOCKING_IO_php7.tar.gz
18# Source0-md5: 7751d8191302a726449d7c6506b8783d
20995d54 19Source1: %{modname}.ini
afdaa3d2
ER
20Source2: %{modname}-apache.conf
21Source3: %{modname}-lighttpd.conf
22Source4: config.php
23Patch0: %{modname}-webapp.patch
8d125064 24Patch1: tests.patch
016f4b1b 25URL: http://pecl.php.net/package/memcache/
3917ea3d 26BuildRequires: %{php_name}-devel >= 3:5.0.0
241a36be 27BuildRequires: %{php_name}-xml
fae887d4 28BuildRequires: php-packagexml2cl
afdaa3d2 29BuildRequires: rpm-php-pearprov >= 4.4.2-11
62a21c7f 30BuildRequires: rpmbuild(macros) >= 1.650
8dfd8797
ER
31%if %{with tests}
32BuildRequires: %{php_name}-cli
af5be609 33BuildRequires: %{php_name}-pcre
8dfd8797 34BuildRequires: %{php_name}-session
ef0230c6 35BuildRequires: %{php_name}-spl
b1a4ab93 36BuildRequires: memcached
8dfd8797 37%endif
0bee29d4 38%{?requires_php_extension}
3917ea3d
ER
39Requires: %{php_name}-session
40Requires: %{php_name}-zlib
afdaa3d2 41Suggests: memcached
bd3aaaff 42Provides: php(memcache) = %{version}
41a892be 43Obsoletes: php-pecl-memcache < 3.0.8-5
15f9ce79
AG
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
afdaa3d2
ER
46%define _webapps /etc/webapps
47%define _webapp %{modname}
48%define _sysconfdir %{_webapps}/%{_webapp}
49%define _appdir %{_datadir}/%{_webapp}
50
51# bad depsolver
52%define _noautopear pear
53
54# put it together for rpmbuild
55%define _noautoreq %{?_noautophp} %{?_noautopear}
56
15f9ce79
AG
57%description
58Memcached is a caching daemon designed especially for dynamic web
59applications to decrease database load by storing objects in memory.
60
61This extension allows you to work with memcached through handy OO and
62procedural interfaces.
63
6dd6de29 64%description -l pl.UTF-8
15f9ce79 65Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
6dd6de29
JR
66daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
67przez przechowywanie w pamięci obiektów.
15f9ce79 68
6dd6de29 69To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
15f9ce79
AG
70zorientowanego obiektowo (oraz przez procedury) interfejsu.
71
afdaa3d2
ER
72%package web
73Summary: Web interface for memcache
74Group: Libraries
09120ee3 75# does not require extension itself
fae887d4 76Requires: php(core) >= %{php_min_version}
3917ea3d
ER
77Requires: php(date)
78Requires: php(gd)
79Requires: php(pcre)
afdaa3d2
ER
80Requires: webapps
81Requires: webserver(php) >= 5.0
3917ea3d
ER
82%if "%{_rpmversion}" >= "5"
83BuildArch: noarch
84%endif
afdaa3d2
ER
85
86%description web
87Via this web interface script you can manage and view statistics of
88memcache.
89
15f9ce79 90%prep
10d2ed2a
ER
91%setup -qc
92mv pecl-%{modname}-*/{.??*,*} .
afdaa3d2 93%patch0 -p1
8d125064 94%patch1 -p1
15f9ce79 95
b1a4ab93
ER
96# locks up on carme, likely due udp very long timeout
97rm tests/039.phpt
98
15f9ce79 99%build
6c6304c8 100packagexml2cl package.xml > ChangeLog
15f9ce79 101phpize
172c079e
AG
102%configure \
103 --with-zlib-dir=/usr
15f9ce79
AG
104%{__make}
105
8dfd8797
ER
106%if %{with tests}
107# simple module load test
108%{__php} -n -q \
109 -d extension_dir=modules \
af5be609 110 -d extension=%{php_extensiondir}/pcre.so \
ef0230c6 111 -d extension=%{php_extensiondir}/spl.so \
8dfd8797
ER
112 -d extension=%{php_extensiondir}/session.so \
113 -d extension=%{modname}.so \
114 -m > modules.log
115grep %{modname} modules.log
e7368be2
ER
116
117cat <<'EOF' > run-tests.sh
118#!/bin/sh
119export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
120exec %{__make} test \
121 PHP_EXECUTABLE=%{__php} \
af5be609 122 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl session" \
e7368be2
ER
123 RUN_TESTS_SETTINGS="-q $*"
124EOF
125chmod +x run-tests.sh
126
b1a4ab93
ER
127# Launch the Memcached service and stop it on exit
128%{_sbindir}/memcached -p 11211 -U 11211 -d -P $PWD/memcached.pid
129trap 'kill $(cat memcached.pid)' EXIT INT
130
e7368be2 131./run-tests.sh
8dfd8797
ER
132%endif
133
15f9ce79
AG
134%install
135rm -rf $RPM_BUILD_ROOT
a9222c27 136install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
20995d54
ER
137install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
138# we use "session_" prefix in inifile to get loader *after* session extension
10d2ed2a
ER
139cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/session_%{modname}.ini
140cp -p example.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
141
142install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
10d2ed2a
ER
143cp -p memcache.php $RPM_BUILD_ROOT%{_appdir}
144cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
145cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
146cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
147cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
15f9ce79
AG
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%post
86295f4f 153%php_webserver_restart
15f9ce79 154
0bee29d4
ER
155%postun
156if [ "$1" = 0 ]; then
86295f4f 157 %php_webserver_restart
15f9ce79
AG
158fi
159
c69936a3
ER
160%triggerpostun -- %{name} < 3.0.4-2
161if [ -f %{php_sysconfdir}/conf.d/%{modname}.ini.rpmsave ]; then
162 echo >&2 "Restoring old config: %{modname}.ini.rpmsave -> session_%{modname}.ini in %{php_sysconfdir}/conf.d"
163 cp -f %{php_sysconfdir}/conf.d/session_%{modname}.ini{,.rpmnew}
164 mv -f %{php_sysconfdir}/conf.d/{%{modname}.ini.rpmsave,session_%{modname}.ini}
165 %php_webserver_restart
166fi
167
afdaa3d2
ER
168%triggerin web -- apache1 < 1.3.37-3, apache1-base
169%webapp_register apache %{_webapp}
170
171%triggerun web -- apache1 < 1.3.37-3, apache1-base
172%webapp_unregister apache %{_webapp}
173
fbc0c377 174%triggerin web -- apache < 2.2.0, apache-base
afdaa3d2
ER
175%webapp_register httpd %{_webapp}
176
fbc0c377 177%triggerun web -- apache < 2.2.0, apache-base
afdaa3d2
ER
178%webapp_unregister httpd %{_webapp}
179
180%triggerin web -- lighttpd
181%webapp_register lighttpd %{_webapp}
182
183%triggerun web -- lighttpd
184%webapp_unregister lighttpd %{_webapp}
185
15f9ce79
AG
186%files
187%defattr(644,root,root,755)
6c6304c8 188%doc CREDITS README ChangeLog
c69936a3 189%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/session_%{modname}.ini
a9222c27
ER
190%attr(755,root,root) %{php_extensiondir}/%{modname}.so
191%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
192
193%files web
194%defattr(644,root,root,755)
195%dir %attr(750,root,http) %{_sysconfdir}
196%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
197%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
198%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
1ec0934f 199%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
afdaa3d2 200%{_appdir}
This page took 0.110057 seconds and 4 git commands to generate.