]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blame - php-pecl-memcache.spec
pcre for i686
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
CommitLineData
8dfd8797
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
3917ea3d 5%define php_name php%{?php_suffix}
a9222c27 6%define modname memcache
afdaa3d2 7%define php_min_version 5.0.0
3917ea3d 8%include /usr/lib/rpm/macros.php
a9222c27
ER
9Summary: %{modname} - a memcached extension
10Summary(pl.UTF-8): %{modname} - rozszerzenie memcached
3917ea3d 11Name: %{php_name}-pecl-%{modname}
10d2ed2a
ER
12Version: 3.0.9
13Release: 1
d7d5fbe6 14License: PHP 3.01
15f9ce79 15Group: Development/Languages/PHP
10d2ed2a
ER
16#Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
17Source0: https://github.com/websupport-sk/pecl-memcache/archive/NON_BLOCKING_IO_php7.tar.gz
18# Source0-md5: 7751d8191302a726449d7c6506b8783d
20995d54 19Source1: %{modname}.ini
afdaa3d2
ER
20Source2: %{modname}-apache.conf
21Source3: %{modname}-lighttpd.conf
22Source4: config.php
23Patch0: %{modname}-webapp.patch
8d125064 24Patch1: tests.patch
016f4b1b 25URL: http://pecl.php.net/package/memcache/
3917ea3d 26BuildRequires: %{php_name}-devel >= 3:5.0.0
241a36be 27BuildRequires: %{php_name}-xml
fae887d4 28BuildRequires: php-packagexml2cl
afdaa3d2 29BuildRequires: rpm-php-pearprov >= 4.4.2-11
62a21c7f 30BuildRequires: rpmbuild(macros) >= 1.650
8dfd8797
ER
31%if %{with tests}
32BuildRequires: %{php_name}-cli
af5be609 33BuildRequires: %{php_name}-pcre
8dfd8797 34BuildRequires: %{php_name}-session
ef0230c6 35BuildRequires: %{php_name}-spl
8dfd8797 36%endif
0bee29d4 37%{?requires_php_extension}
3917ea3d
ER
38Requires: %{php_name}-session
39Requires: %{php_name}-zlib
afdaa3d2 40Suggests: memcached
bd3aaaff 41Provides: php(memcache) = %{version}
41a892be 42Obsoletes: php-pecl-memcache < 3.0.8-5
15f9ce79
AG
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
afdaa3d2
ER
45%define _webapps /etc/webapps
46%define _webapp %{modname}
47%define _sysconfdir %{_webapps}/%{_webapp}
48%define _appdir %{_datadir}/%{_webapp}
49
50# bad depsolver
51%define _noautopear pear
52
53# put it together for rpmbuild
54%define _noautoreq %{?_noautophp} %{?_noautopear}
55
15f9ce79
AG
56%description
57Memcached is a caching daemon designed especially for dynamic web
58applications to decrease database load by storing objects in memory.
59
60This extension allows you to work with memcached through handy OO and
61procedural interfaces.
62
6dd6de29 63%description -l pl.UTF-8
15f9ce79 64Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
6dd6de29
JR
65daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
66przez przechowywanie w pamięci obiektów.
15f9ce79 67
6dd6de29 68To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
15f9ce79
AG
69zorientowanego obiektowo (oraz przez procedury) interfejsu.
70
afdaa3d2
ER
71%package web
72Summary: Web interface for memcache
73Group: Libraries
09120ee3 74# does not require extension itself
fae887d4 75Requires: php(core) >= %{php_min_version}
3917ea3d
ER
76Requires: php(date)
77Requires: php(gd)
78Requires: php(pcre)
afdaa3d2
ER
79Requires: webapps
80Requires: webserver(php) >= 5.0
3917ea3d
ER
81%if "%{_rpmversion}" >= "5"
82BuildArch: noarch
83%endif
afdaa3d2
ER
84
85%description web
86Via this web interface script you can manage and view statistics of
87memcache.
88
15f9ce79 89%prep
10d2ed2a
ER
90%setup -qc
91mv pecl-%{modname}-*/{.??*,*} .
afdaa3d2 92%patch0 -p1
8d125064 93%patch1 -p1
15f9ce79
AG
94
95%build
6c6304c8 96packagexml2cl package.xml > ChangeLog
15f9ce79 97phpize
172c079e
AG
98%configure \
99 --with-zlib-dir=/usr
15f9ce79
AG
100%{__make}
101
8dfd8797
ER
102%if %{with tests}
103# simple module load test
104%{__php} -n -q \
105 -d extension_dir=modules \
af5be609 106 -d extension=%{php_extensiondir}/pcre.so \
ef0230c6 107 -d extension=%{php_extensiondir}/spl.so \
8dfd8797
ER
108 -d extension=%{php_extensiondir}/session.so \
109 -d extension=%{modname}.so \
110 -m > modules.log
111grep %{modname} modules.log
e7368be2
ER
112
113cat <<'EOF' > run-tests.sh
114#!/bin/sh
115export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
116exec %{__make} test \
117 PHP_EXECUTABLE=%{__php} \
af5be609 118 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl session" \
e7368be2
ER
119 RUN_TESTS_SETTINGS="-q $*"
120EOF
121chmod +x run-tests.sh
122
123./run-tests.sh
8dfd8797
ER
124%endif
125
15f9ce79
AG
126%install
127rm -rf $RPM_BUILD_ROOT
a9222c27 128install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
20995d54
ER
129install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
130# we use "session_" prefix in inifile to get loader *after* session extension
10d2ed2a
ER
131cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/session_%{modname}.ini
132cp -p example.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
133
134install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
10d2ed2a
ER
135cp -p memcache.php $RPM_BUILD_ROOT%{_appdir}
136cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
137cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
138cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
139cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
15f9ce79
AG
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%post
86295f4f 145%php_webserver_restart
15f9ce79 146
0bee29d4
ER
147%postun
148if [ "$1" = 0 ]; then
86295f4f 149 %php_webserver_restart
15f9ce79
AG
150fi
151
c69936a3
ER
152%triggerpostun -- %{name} < 3.0.4-2
153if [ -f %{php_sysconfdir}/conf.d/%{modname}.ini.rpmsave ]; then
154 echo >&2 "Restoring old config: %{modname}.ini.rpmsave -> session_%{modname}.ini in %{php_sysconfdir}/conf.d"
155 cp -f %{php_sysconfdir}/conf.d/session_%{modname}.ini{,.rpmnew}
156 mv -f %{php_sysconfdir}/conf.d/{%{modname}.ini.rpmsave,session_%{modname}.ini}
157 %php_webserver_restart
158fi
159
afdaa3d2
ER
160%triggerin web -- apache1 < 1.3.37-3, apache1-base
161%webapp_register apache %{_webapp}
162
163%triggerun web -- apache1 < 1.3.37-3, apache1-base
164%webapp_unregister apache %{_webapp}
165
fbc0c377 166%triggerin web -- apache < 2.2.0, apache-base
afdaa3d2
ER
167%webapp_register httpd %{_webapp}
168
fbc0c377 169%triggerun web -- apache < 2.2.0, apache-base
afdaa3d2
ER
170%webapp_unregister httpd %{_webapp}
171
172%triggerin web -- lighttpd
173%webapp_register lighttpd %{_webapp}
174
175%triggerun web -- lighttpd
176%webapp_unregister lighttpd %{_webapp}
177
15f9ce79
AG
178%files
179%defattr(644,root,root,755)
6c6304c8 180%doc CREDITS README ChangeLog
c69936a3 181%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/session_%{modname}.ini
a9222c27
ER
182%attr(755,root,root) %{php_extensiondir}/%{modname}.so
183%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
184
185%files web
186%defattr(644,root,root,755)
187%dir %attr(750,root,http) %{_sysconfdir}
188%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
189%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
190%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
1ec0934f 191%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
afdaa3d2 192%{_appdir}
This page took 0.103474 seconds and 4 git commands to generate.