]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blame - php-pecl-memcache.spec
up to e702b5f91 snapshot
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
CommitLineData
8dfd8797
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
3917ea3d 5%define php_name php%{?php_suffix}
a9222c27 6%define modname memcache
afdaa3d2 7%define php_min_version 5.0.0
7362daf0 8%define commit e702b5f91
3917ea3d 9%include /usr/lib/rpm/macros.php
a9222c27
ER
10Summary: %{modname} - a memcached extension
11Summary(pl.UTF-8): %{modname} - rozszerzenie memcached
3917ea3d 12Name: %{php_name}-pecl-%{modname}
10d2ed2a 13Version: 3.0.9
7362daf0 14Release: 2
d7d5fbe6 15License: PHP 3.01
15f9ce79 16Group: Development/Languages/PHP
10d2ed2a 17#Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
7362daf0
ER
18# https://github.com/websupport-sk/pecl-memcache/commits/NON_BLOCKING_IO_php7
19Source0: https://github.com/websupport-sk/pecl-memcache/archive/%{commit}/%{modname}-%{version}-%{commit}.tar.gz
20# Source0-md5: 945e6a30b3cac160abf9b6d103c5676b
20995d54 21Source1: %{modname}.ini
afdaa3d2
ER
22Source2: %{modname}-apache.conf
23Source3: %{modname}-lighttpd.conf
24Source4: config.php
25Patch0: %{modname}-webapp.patch
016f4b1b 26URL: http://pecl.php.net/package/memcache/
3917ea3d 27BuildRequires: %{php_name}-devel >= 3:5.0.0
241a36be 28BuildRequires: %{php_name}-xml
fae887d4 29BuildRequires: php-packagexml2cl
afdaa3d2 30BuildRequires: rpm-php-pearprov >= 4.4.2-11
62a21c7f 31BuildRequires: rpmbuild(macros) >= 1.650
8dfd8797
ER
32%if %{with tests}
33BuildRequires: %{php_name}-cli
af5be609 34BuildRequires: %{php_name}-pcre
8dfd8797 35BuildRequires: %{php_name}-session
ef0230c6 36BuildRequires: %{php_name}-spl
b1a4ab93 37BuildRequires: memcached
8dfd8797 38%endif
0bee29d4 39%{?requires_php_extension}
3917ea3d
ER
40Requires: %{php_name}-session
41Requires: %{php_name}-zlib
afdaa3d2 42Suggests: memcached
bd3aaaff 43Provides: php(memcache) = %{version}
41a892be 44Obsoletes: php-pecl-memcache < 3.0.8-5
15f9ce79
AG
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
afdaa3d2
ER
47%define _webapps /etc/webapps
48%define _webapp %{modname}
49%define _sysconfdir %{_webapps}/%{_webapp}
50%define _appdir %{_datadir}/%{_webapp}
51
52# bad depsolver
53%define _noautopear pear
54
55# put it together for rpmbuild
56%define _noautoreq %{?_noautophp} %{?_noautopear}
57
15f9ce79
AG
58%description
59Memcached is a caching daemon designed especially for dynamic web
60applications to decrease database load by storing objects in memory.
61
62This extension allows you to work with memcached through handy OO and
63procedural interfaces.
64
6dd6de29 65%description -l pl.UTF-8
15f9ce79 66Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
6dd6de29
JR
67daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
68przez przechowywanie w pamięci obiektów.
15f9ce79 69
6dd6de29 70To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
15f9ce79
AG
71zorientowanego obiektowo (oraz przez procedury) interfejsu.
72
afdaa3d2
ER
73%package web
74Summary: Web interface for memcache
75Group: Libraries
09120ee3 76# does not require extension itself
fae887d4 77Requires: php(core) >= %{php_min_version}
3917ea3d
ER
78Requires: php(date)
79Requires: php(gd)
80Requires: php(pcre)
afdaa3d2
ER
81Requires: webapps
82Requires: webserver(php) >= 5.0
3917ea3d
ER
83%if "%{_rpmversion}" >= "5"
84BuildArch: noarch
85%endif
afdaa3d2
ER
86
87%description web
88Via this web interface script you can manage and view statistics of
89memcache.
90
15f9ce79 91%prep
10d2ed2a
ER
92%setup -qc
93mv pecl-%{modname}-*/{.??*,*} .
afdaa3d2 94%patch0 -p1
15f9ce79 95
b1a4ab93
ER
96# locks up on carme, likely due udp very long timeout
97rm tests/039.phpt
85fa36ce
ER
98rm tests/041.phpt
99rm tests/042.phpt
100
101# skip failed tests
102xfail() {
103 set +x
104 while read s; do
105 t=$(echo "$s" | sed -rne 's/.+\[(.+)\]/\1/p')
106
107 test -f "$t"
108 echo >&2 "XFAIL: $s"
109 cat >> $t <<-EOF
110
111 --XFAIL--
112 Skip
113 EOF
114 done
115}
116
117xfail <<'EOF'
118memcache->addServer() [tests/019.phpt]
119memcache->set()/memcache->get() with multiple keys and load balancing [tests/020.phpt]
120memcache->getExtendedStats() [tests/022.phpt]
121memcache_get_extended_stats() [tests/022a.phpt]
122memcache->delete() with load balancing [tests/023.phpt]
123memcache->increment() with load balancing [tests/025.phpt]
124memcache->delete() with load balancing [tests/026.phpt]
125memcache->addServer() adding server in failed mode [tests/031.phpt]
126memcache->getServerStatus(), memcache->setServerParams() [tests/032.phpt]
127memcache::connect() with unix domain socket [tests/035.phpt]
128memcache->get() over UDP [tests/038.phpt]
129memcache->increment()/decrement() with multiple keys [tests/040.phpt]
130ini_set('memcache.redundancy') [tests/043.phpt]
131ini_set('memcache.session_redundancy') [tests/044.phpt]
132hash strategies and functions [tests/046.phpt]
133ini_set('session.save_handler') with unix domain socket [tests/053.phpt]
134FLAKY: memcache->addServer() with microsecond timeout [tests/056.phpt]
d41cf5ce 135ini_set('session.save_handler') [tests/036.phpt]
c6406d16 136ini_set("memcache.allow_failover") [tests/029.phpt]
b5fd9090
ER
137%if "%{php_major_version}.%{php_minor_version}" >= "7.1"
138strange keys [tests/005.phpt]
139%endif
85fa36ce 140EOF
b1a4ab93 141
15f9ce79 142%build
6c6304c8 143packagexml2cl package.xml > ChangeLog
15f9ce79 144phpize
172c079e
AG
145%configure \
146 --with-zlib-dir=/usr
15f9ce79
AG
147%{__make}
148
8dfd8797
ER
149%if %{with tests}
150# simple module load test
151%{__php} -n -q \
152 -d extension_dir=modules \
af5be609 153 -d extension=%{php_extensiondir}/pcre.so \
ef0230c6 154 -d extension=%{php_extensiondir}/spl.so \
8dfd8797
ER
155 -d extension=%{php_extensiondir}/session.so \
156 -d extension=%{modname}.so \
157 -m > modules.log
158grep %{modname} modules.log
e7368be2
ER
159
160cat <<'EOF' > run-tests.sh
161#!/bin/sh
162export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
163exec %{__make} test \
164 PHP_EXECUTABLE=%{__php} \
af5be609 165 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl session" \
e7368be2
ER
166 RUN_TESTS_SETTINGS="-q $*"
167EOF
168chmod +x run-tests.sh
169
b1a4ab93
ER
170# Launch the Memcached service and stop it on exit
171%{_sbindir}/memcached -p 11211 -U 11211 -d -P $PWD/memcached.pid
172trap 'kill $(cat memcached.pid)' EXIT INT
173
e7368be2 174./run-tests.sh
8dfd8797
ER
175%endif
176
15f9ce79
AG
177%install
178rm -rf $RPM_BUILD_ROOT
a9222c27 179install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
20995d54
ER
180install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
181# we use "session_" prefix in inifile to get loader *after* session extension
10d2ed2a
ER
182cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/session_%{modname}.ini
183cp -p example.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
184
185install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
10d2ed2a
ER
186cp -p memcache.php $RPM_BUILD_ROOT%{_appdir}
187cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
188cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
189cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
190cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
15f9ce79
AG
191
192%clean
193rm -rf $RPM_BUILD_ROOT
194
195%post
86295f4f 196%php_webserver_restart
15f9ce79 197
0bee29d4
ER
198%postun
199if [ "$1" = 0 ]; then
86295f4f 200 %php_webserver_restart
15f9ce79
AG
201fi
202
c69936a3
ER
203%triggerpostun -- %{name} < 3.0.4-2
204if [ -f %{php_sysconfdir}/conf.d/%{modname}.ini.rpmsave ]; then
205 echo >&2 "Restoring old config: %{modname}.ini.rpmsave -> session_%{modname}.ini in %{php_sysconfdir}/conf.d"
206 cp -f %{php_sysconfdir}/conf.d/session_%{modname}.ini{,.rpmnew}
207 mv -f %{php_sysconfdir}/conf.d/{%{modname}.ini.rpmsave,session_%{modname}.ini}
208 %php_webserver_restart
209fi
210
afdaa3d2
ER
211%triggerin web -- apache1 < 1.3.37-3, apache1-base
212%webapp_register apache %{_webapp}
213
214%triggerun web -- apache1 < 1.3.37-3, apache1-base
215%webapp_unregister apache %{_webapp}
216
fbc0c377 217%triggerin web -- apache < 2.2.0, apache-base
afdaa3d2
ER
218%webapp_register httpd %{_webapp}
219
fbc0c377 220%triggerun web -- apache < 2.2.0, apache-base
afdaa3d2
ER
221%webapp_unregister httpd %{_webapp}
222
223%triggerin web -- lighttpd
224%webapp_register lighttpd %{_webapp}
225
226%triggerun web -- lighttpd
227%webapp_unregister lighttpd %{_webapp}
228
15f9ce79
AG
229%files
230%defattr(644,root,root,755)
6c6304c8 231%doc CREDITS README ChangeLog
c69936a3 232%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/session_%{modname}.ini
a9222c27
ER
233%attr(755,root,root) %{php_extensiondir}/%{modname}.so
234%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
235
236%files web
237%defattr(644,root,root,755)
238%dir %attr(750,root,http) %{_sysconfdir}
239%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
240%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
241%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
1ec0934f 242%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
afdaa3d2 243%{_appdir}
This page took 0.107042 seconds and 4 git commands to generate.