]> git.pld-linux.org Git - packages/php-pecl-libsodium.git/blame - php-pecl-libsodium.spec
- updated to 1.0.7, pl
[packages/php-pecl-libsodium.git] / php-pecl-libsodium.spec
CommitLineData
9ce6e03e
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
ce01d2b9
ER
5%define buildver %(pkg-config --silence-errors --modversion libsodium 2>/dev/null || echo 65536)
6
9ce6e03e
ER
7%define php_name php%{?php_suffix}
8%define modname libsodium
9Summary: Wrapper for the Sodium cryptographic library
abeee5f1 10Summary(pl.UTF-8): Interfejs do biblioteki kryptograficznej Sodium
ce01d2b9 11Name: %{php_name}-pecl-%{modname}
abeee5f1 12Version: 1.0.7
9ce6e03e
ER
13Release: 1
14License: BSD
15Group: Development/Languages
16Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
abeee5f1 17# Source0-md5: d8edb46a03268c45bfca7951d5e7c57a
9ce6e03e 18URL: http://pecl.php.net/package/libsodium
9ce6e03e
ER
19BuildRequires: %{php_name}-devel >= 4:5.3
20BuildRequires: libsodium-devel >= 0.6.0
21BuildRequires: pkgconfig
22BuildRequires: rpmbuild(macros) >= 1.666
23%if %{with tests}
24BuildRequires: %{php_name}-cli
25BuildRequires: %{php_name}-json
26%endif
27Requires: libsodium >= %{buildver}
28%{?requires_php_extension}
29Provides: php(libsodium) = %{version}
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33A simple, low-level PHP extension for libsodium.
34
35Documentation: https://paragonie.com/book/pecl-libsodium
36
abeee5f1
JB
37%description -l pl.UTF-8
38Proste, niskopoziomowe rozszerzenie PHP do libsodium.
39
40Dokumentacja: https://paragonie.com/book/pecl-libsodium
41
9ce6e03e
ER
42%prep
43%setup -qc
abeee5f1 44%{__mv} %{modname}-%{version}/* .
9ce6e03e 45
ce01d2b9 46%build
9ce6e03e
ER
47# Sanity check, really often broken
48extver=$(sed -n '/#define PHP_LIBSODIUM_VERSION/{s/.* "//;s/".*$//;p}' php_libsodium.h)
49if test "x${extver}" != "x%{version}"; then
50 : Error: Upstream extension version is ${extver}, expecting %{version}.
51 exit 1
52fi
53
9ce6e03e
ER
54phpize
55%configure
56%{__make}
57
58%if %{with tests}
59: Minimal load test
60%{__php} -n \
61 -d extension_dir=modules \
62 -d extension=%{modname}.so \
63 -m > modules.log
64grep %{modname} modules.log
65
66: Upstream test suite
67export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
68%{__make} test \
69 PHP_EXECUTABLE=%{__php} \
70 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="json" \
71%endif
72
73%install
74rm -rf $RPM_BUILD_ROOT
75%{__make} install \
76 EXTENSION_DIR=%{php_extensiondir} \
77 INSTALL_ROOT=$RPM_BUILD_ROOT
78
79install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
80cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
81; Enable %{modname} extension module
82extension=%{modname}.so
83EOF
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post
89%php_webserver_restart
90
91%postun
92if [ "$1" = 0 ]; then
93 %php_webserver_restart
94fi
95
96%files
97%defattr(644,root,root,755)
98%doc README.md LICENSE
99%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
100%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.104042 seconds and 4 git commands to generate.