]> git.pld-linux.org Git - packages/php-pecl-imagick.git/commitdiff
use xfail; skip more tests on x32 auto/th/php-pecl-imagick-3.4.2-3
authorElan Ruusamäe <glen@delfi.ee>
Wed, 2 Nov 2016 22:16:42 +0000 (00:16 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 2 Nov 2016 22:17:06 +0000 (00:17 +0200)
php-pecl-imagick.spec

index 67c891665a56075bed258fd80a0d48a8c90657e6..9d8b45073402e76dde3ec71105b805d2eee07142 100644 (file)
@@ -65,12 +65,20 @@ To rozszerzenie ma w PECL status: %{status}.
 mv %{modname}-%{version}/* .
 %patch0 -p1
 
 mv %{modname}-%{version}/* .
 %patch0 -p1
 
-# skip failing tests
+xfail() {
+       t=$1
+       cat >> $t <<-EOF
+
+       --XFAIL--
+       Skip
+       EOF
+}
 Test() {
        nf=$(eval echo \$$#)
        t=$nf; t=${t#\[}; t=${t%\]}
 Test() {
        nf=$(eval echo \$$#)
        t=$nf; t=${t#\[}; t=${t%\]}
-       mv $t $t.skip
+       xfail $t
 }
 }
+# skip failing tests
 Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
 Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
 Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
 Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
 Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
 Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
@@ -86,6 +94,13 @@ Test ImagickDraw, setTextDecoration [tests/225_ImagickDraw_setTextDecoration_bas
 Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
 Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
 Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
 Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
 Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
 Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
+%ifarch x32
+# Fail on 7.0
+Test Imagick, quantizeImage [tests/101_Imagick_quantizeImage_basic.phpt]
+Test Imagick, uniqueImageColors [tests/163_Imagick_uniqueImageColors_basic.phpt]
+Test Tutorial, deconstructGif [tests/237_Tutorial_deconstructGif_basic.phpt]
+Test ImagickPixelIterator, setIteratorRow [tests/251_ImagickPixelIterator_setIteratorRow_basic.phpt]
+%endif
 
 %build
 phpize
 
 %build
 phpize
This page took 0.05436 seconds and 4 git commands to generate.