]> git.pld-linux.org Git - packages/php-pecl-imagick.git/commitdiff
Update failed tests
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 5 Mar 2021 14:29:01 +0000 (16:29 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Fri, 5 Mar 2021 14:29:01 +0000 (16:29 +0200)
php-pecl-imagick.spec

index 65c41b59e97bbfc9c171e29495c2abf7029c9391..171ec2c12db6a6ce4be9cbb2b62938a4ab0766af 100644 (file)
@@ -68,18 +68,21 @@ mv %{modname}-%{version}/* .
 %patch0 -p1
 
 xfail() {
-       t=$1
+       local t=$1
+       test -f $t
        cat >> $t <<-EOF
 
        --XFAIL--
        Skip
        EOF
 }
-Test() {
-       nf=$(eval echo \$$#)
-       t=$nf; t=${t#\[}; t=${t%\]}
+
+while read line; do
+       t=${line##*\[}; t=${t%\]}
+       test -z "$t" -o "${t:0:1}" = '#' && continue
        xfail $t
-}
+done << 'EOF'
+
 # skip failing tests
 Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
 Test Imagick, setRegistry and getRegistry [tests/150_Imagick_setregistry.phpt]
@@ -110,6 +113,13 @@ Test ImagickPixelIterator, setIteratorRow [tests/251_ImagickPixelIterator_setIte
 # Fail on 5.3, 5.5, 5.6, 7.0, 7.1, 7.2
 Test Tutorial, fxAnalyzeImage [tests/229_Tutorial_fxAnalyzeImage_case1.phpt]
 
+# 5.3, 5.5, 5.6, 7.0/x32, 7.1, 7.2, 7.3, 7.4
+ImagickKernel::fromMatrix exceptions [tests/280_imagickkernel_exception_invalid_origin.phpt]
+Imagick::setImageAlpha [tests/274_imagick_setImageAlpha.phpt]
+Test ImagickDraw:: setTextInterlineSpacing [tests/279_ImagickDraw_setTextInterlineSpacing.phpt]
+Test Imagick::optimizeimagelayers and Imagick::optimizeimagetransparency [tests/278_Imagick_optimaze_gif.phpt]
+EOF
+
 %build
 phpize
 %configure \
This page took 0.155744 seconds and 4 git commands to generate.