]> git.pld-linux.org Git - packages/php-pecl-imagick.git/commitdiff
skip stupid version check auto/th/php-pecl-imagick-3.4.2-2
authorElan Ruusamäe <glen@delfi.ee>
Tue, 30 Aug 2016 09:07:04 +0000 (12:07 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 30 Aug 2016 09:07:04 +0000 (12:07 +0300)
it will just pollute cron mails that use php cli:

$ php -r ''
PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1684 but version 1685 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0

php-pecl-imagick.spec
skip_version_check.patch [new file with mode: 0644]

index 4ceb62f1fd7f432f783599ab4cbafaa68bba42b4..79b1ad24819b055831b7123d6a2ef1eb2243ce47 100644 (file)
@@ -5,11 +5,12 @@ Summary:      %{modname} - PHP wrapper to the Image Magick Library
 Summary(pl.UTF-8):     %{modname} - PHP-owy wrapper do biblioteki Image Magick
 Name:          %{php_name}-pecl-%{modname}
 Version:       3.4.2
-Release:       1
+Release:       2
 License:       PHP 3.01
 Group:         Development/Languages/PHP
 Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: 3f80e35c2434636cdb5df01b221b3ffa
+Patch0:                skip_version_check.patch
 URL:           http://pecl.php.net/package/imagick/
 BuildRequires: %{php_name}-devel >= 4:5.3
 BuildRequires: ImageMagick-devel >= 1:6.2.4.0
@@ -45,8 +46,9 @@ zmniejszać ilość kolorów - w tym samym lub innym formacie.
 To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
+%setup -qc
 mv %{modname}-%{version}/* .
+%patch0 -p1
 
 %build
 phpize
diff --git a/skip_version_check.patch b/skip_version_check.patch
new file mode 100644 (file)
index 0000000..ccfed26
--- /dev/null
@@ -0,0 +1,20 @@
+--- php55-pecl-imagick-3.4.2/./imagick.c~      2016-04-25 01:51:17.000000000 +0300
++++ php55-pecl-imagick-3.4.2/./imagick.c       2016-08-30 12:06:18.534956682 +0300
+@@ -3173,7 +3173,7 @@
+ PHP_INI_BEGIN()
+       STD_PHP_INI_ENTRY("imagick.locale_fix", "0", PHP_INI_ALL, OnUpdateBool, locale_fix, zend_imagick_globals, imagick_globals)
+-      STD_PHP_INI_ENTRY("imagick.skip_version_check", "0", PHP_INI_ALL, OnUpdateBool, skip_version_check, zend_imagick_globals, imagick_globals)
++      STD_PHP_INI_ENTRY("imagick.skip_version_check", "1", PHP_INI_ALL, OnUpdateBool, skip_version_check, zend_imagick_globals, imagick_globals)
+       STD_PHP_INI_ENTRY("imagick.progress_monitor", "0", PHP_INI_SYSTEM, OnUpdateBool, progress_monitor, zend_imagick_globals, imagick_globals)
+ PHP_INI_END()
+@@ -3181,7 +3181,7 @@
+ {
+       imagick_globals->locale_fix = 0;
+       imagick_globals->progress_monitor = 0;
+-      imagick_globals->skip_version_check = 0;
++      imagick_globals->skip_version_check = 1;
+ }
This page took 0.140699 seconds and 4 git commands to generate.