]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blobdiff - php-pecl-imagick.spec
Rel 4
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
index 65c41b59e97bbfc9c171e29495c2abf7029c9391..fe43eca8f03c05fe700a24ca9ecd8d1fabbdd453 100644 (file)
@@ -9,12 +9,12 @@
 Summary:       %{modname} - PHP wrapper to the Image Magick Library
 Summary(pl.UTF-8):     %{modname} - PHP-owy wrapper do biblioteki Image Magick
 Name:          %{php_name}-pecl-%{modname}
-Version:       3.4.4
-Release:       5
+Version:       3.7.0
+Release:       4
 License:       PHP 3.01
 Group:         Development/Languages/PHP
 Source0:       https://pecl.php.net/get/%{modname}-%{version}.tgz
-# Source0-md5: 6d3a7048ab73b0fab931f28c484dbf76
+# Source0-md5: 0687774a6126467d4e5ede02171e981d
 Patch0:                skip_version_check.patch
 URL:           https://pecl.php.net/package/imagick
 BuildRequires: %{php_name}-cli
@@ -68,18 +68,24 @@ mv %{modname}-%{version}/* .
 %patch0 -p1
 
 xfail() {
-       t=$1
+       local t=$1
+       test -f $t
        cat >> $t <<-EOF
 
        --XFAIL--
        Skip
        EOF
 }
-Test() {
-       nf=$(eval echo \$$#)
-       t=$nf; t=${t#\[}; t=${t%\]}
+
+while read line; do
+       t=${line##*\[}; t=${t%\]}
+       test -z "$t" && continue
+       case "$t" in
+               '#'*) continue;;
+       esac
        xfail $t
-}
+done << 'EOF'
+
 # skip failing tests
 Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
 Test Imagick, setRegistry and getRegistry [tests/150_Imagick_setregistry.phpt]
@@ -110,6 +116,38 @@ Test ImagickPixelIterator, setIteratorRow [tests/251_ImagickPixelIterator_setIte
 # Fail on 5.3, 5.5, 5.6, 7.0, 7.1, 7.2
 Test Tutorial, fxAnalyzeImage [tests/229_Tutorial_fxAnalyzeImage_case1.phpt]
 
+# 5.3, 5.5, 5.6, 7.0/x32, 7.1, 7.2, 7.3, 7.4
+ImagickKernel::fromMatrix exceptions [tests/280_imagickkernel_exception_invalid_origin.phpt]
+Imagick::setImageAlpha [tests/274_imagick_setImageAlpha.phpt]
+Test ImagickDraw:: setTextInterlineSpacing [tests/279_ImagickDraw_setTextInterlineSpacing.phpt]
+Test Imagick::optimizeimagelayers and Imagick::optimizeimagetransparency [tests/278_Imagick_optimaze_gif.phpt]
+
+# php73/x32
+Test PHP bug #59378 writing to php://memory is incomplete [tests/bug59378.phpt]
+
+# php 7.4, 8.0
+%if "%php_major_version.%php_minor_version" == "7.4"
+Casting color and opacity to pixel [tests/003_cast_color_opacity.phpt]
+Different types of thumbnailing [tests/002_thumbnail.phpt]
+ImagickKernel::fromMatrix test [tests/145_imagickkernel_coverage.phpt]
+Imagick::resizeImage prevent 0 width/height images [tests/github_174.phpt]
+Test autoGammaImage [tests/263_autoGammaImage.phpt]
+Test compositeImageGravity [tests/261_compositeImageGravity.phpt]
+Test cropthumbnail [tests/006_cropthumbnail.phpt]
+Test filling thumbnail with color [tests/007_thumbnail_fill.phpt]
+Test for round issues [tests/064_cropThumbNailImage.phpt]
+Test Imagick::colorDecisionListImage [tests/277_Imagick_colorDecisionListImage.phpt]
+Test Imagick, progressMonitor [tests/127_Imagick_progressMonitor_basic.phpt]
+Test importimagepixels [tests/010_importimagepixels.phpt]
+Testing clone keyword [tests/004_clone.phpt]
+Testing that cloned object does not affect the original [tests/012-clone-separation.phpt]
+Test thumbnail bestfit [tests/005_bestfit.phpt]
+%ifarch x32 %{ix86}
+Test localContrastImage [tests/260_localContrastImage.phpt]
+%endif
+%endif
+EOF
+
 %build
 phpize
 %configure \
This page took 0.092732 seconds and 4 git commands to generate.