]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
- release 3
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 %define         modname imagick
2 %define         status          stable
3 Summary:        %{modname} - PHP wrapper to the Image Magick Library
4 Summary(pl.UTF-8):      %{modname} - PHP-owy wrapper do biblioteki Image Magick
5 Name:           php-pecl-%{modname}
6 Version:        2.3.0
7 Release:        3
8 License:        PHP 3.01
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
11 # Source0-md5:  29f99195c841ab4d36797bbc47b2b215
12 URL:            http://pecl.php.net/package/imagick/
13 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
14 BuildRequires:  php-devel >= 3:5.1.3
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 %{?requires_php_extension}
17 Requires(triggerpostun):        sed >= 4.0
18 Requires:       php-common >= 4:5.0.4
19 Provides:       php(imagick)
20 Obsoletes:      php-imagick
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ImageMagick is a robust collection of tools and libraries to read,
25 write, and manipulate an image in many image formats (over 68 major
26 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
27 and GIF. With ImageMagick you can create images dynamically, making it
28 suitable for Web applications. You can also resize, rotate, sharpen,
29 color reduce, or add special effects to an image and save your
30 completed work in the same or differing image format.
31
32 In PECL status of this package is: %{status}.
33
34 %description -l pl.UTF-8
35 ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
36 modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
37 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
38 ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
39 aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
40 zmniejszać ilość kolorów - w tym samym lub innym formacie.
41
42 To rozszerzenie ma w PECL status: %{status}.
43
44 %prep
45 %setup -q -c
46 mv %{modname}-%{version}/* .
47
48 %build
49 phpize
50 %configure
51
52 %{__make} \
53         CFLAGS_CLEAN="%{rpmcflags}"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
58 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
59 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
60 ; Enable %{modname} extension module
61 extension=%{modname}.so
62 EOF
63 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post
69 %php_webserver_restart
70
71 %postun
72 if [ "$1" = 0 ]; then
73         %php_webserver_restart
74 fi
75
76 %triggerpostun -- %{name} < 0.9.11-2.1
77 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
78
79 %files
80 %defattr(644,root,root,755)
81 %doc CREDITS
82 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
83 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
84 %{_examplesdir}/%{name}-%{version}
This page took 0.124159 seconds and 4 git commands to generate.