]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
- do not use macros in URL
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 %define         _modname        imagick
2 %define         _status         beta
3 Summary:        PHP wrapper to the Image Magick Library
4 Summary(pl):    PHP-owy wrapper do biblioteki Image Magick
5 Name:           php-pecl-%{_modname}
6 Version:        0.9.8
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  146eae38aedcf39cf9bf10cfd3078b57
12 URL:            http://pear.php.net/package/imagick/
13 BuildRequires:  ImageMagick-devel
14 BuildRequires:  php-devel
15 Requires:       php-common
16 Obsoletes:      php-imagick
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _sysconfdir     /etc/php
20 %define         extensionsdir   %{_libdir}/php
21
22 %description
23 ImageMagick is a robust collection of tools and libraries to read,
24 write, and manipulate an image in many image formats (over 68 major
25 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
26 and GIF. With ImageMagick you can create images dynamically, making it
27 suitable for Web applications. You can also resize, rotate, sharpen,
28 color reduce, or add special effects to an image and save your
29 completed work in the same or differing image format.
30
31 This class has in PEAR status: %{_status}.
32
33 %description -l pl
34 ImageMagick to du¿y zestaw narzêdzi i bibliotek do odczytu, zapisu i
35 modyfikowania obrazków w wielu formatach (ponad 68 g³ównych), w tym
36 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomoc±
37 ImageMagick mo¿na dynamicznie tworzyæ obrazki, co jest przydatne w
38 aplikacjach WWW. Mo¿na je tak¿e przeskalowywaæ, obracaæ, wyostrzaæ,
39 zmniejszaæ ilo¶æ kolorów - w tym samym lub innym formacie.
40
41 Ta klasa ma w PEAR status: %{_status}.
42
43 %prep
44 %setup -q -c
45
46 %build
47 cd %{_modname}-%{version}
48 phpize
49 %configure \
50         --with-%{_modname}=/usr/X11R6/include/X11/
51
52 %{__make} \
53         CPPFLAGS="-DHAVE_CONFIG_H -I/usr/X11R6/include/X11/" \
54         CFLAGS_CLEAN="%{rpmcflags}"
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{extensionsdir}
59
60 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php.ini
67
68 %preun
69 if [ "$1" = "0" ]; then
70         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php.ini
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc %{_modname}-%{version}/examples/{*.php,*.jpg,*.gif}
76 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.074888 seconds and 4 git commands to generate.