]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
- renamed package with binary pear class from php-pear-class to php-pecl-class
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 Summary:        PHP wrapper to the Image Magick Library
2 Summary(pl):    PHP-owy wrapper do biblioteki Image Magick
3 Name:           php-pecl-imagick
4 Version:        0.1.2
5 Release:        1
6 License:        PHP 2.02
7 Group:          Development/Languages/PHP
8 Source0:        http://pear.php.net/get/imagick-%{version}.tgz
9 URL:            http://pear.php.net/
10 BuildRequires:  ImageMagick-devel
11 BuildRequires:  php-devel
12 Requires:       php-common
13 Obsoletes:      php-imagick
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _sysconfdir     /etc/php
17 %define         extensionsdir   %{_libdir}/php
18
19 %description
20 ImageMagick is a robust collection of tools and libraries to read,
21 write, and manipulate an image in many image formats (over 68 major
22 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
23 and GIF. With ImageMagick you can create images dynamically, making it
24 suitable for Web applications. You can also resize, rotate, sharpen,
25 color reduce, or add special effects to an image and save your
26 completed work in the same or differing image format.
27
28 %description -l pl
29 ImageMagick to du¿y zestaw narzêdzi i bibliotek do odczytu, zapisu i
30 modyfikowania obrazków w wielu formatach (ponad 68 g³ównych), w tym
31 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomoc±
32 ImageMagick mo¿na dynamicznie tworzyæ obrazki, co jest przydatne w
33 aplikacjach WWW. Mo¿na je tak¿e przeskalowywaæ, obracaæ, wyostrzaæ,
34 zmniejszaæ ilo¶æ kolorów - w tym samym lub innym formacie.
35
36 %prep
37 %setup -q -c
38
39 %build
40 cd imagick-%{version}
41 phpize
42 %configure \
43         --with-imagick=/usr/X11R6/include/X11/
44
45 %{__make} CPPFLAGS="-DHAVE_CONFIG_H -I/usr/X11R6/include/X11/"
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{extensionsdir}
50
51 install imagick-%{version}/modules/imagick.so $RPM_BUILD_ROOT%{extensionsdir}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %{_sbindir}/php-module-install install imagick %{_sysconfdir}/php.ini
58
59 %preun
60 if [ "$1" = "0" ]; then
61         %{_sbindir}/php-module-install remove imagick %{_sysconfdir}/php.ini
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc imagick-%{version}/{CREDITS,EXPERIMENTAL,*.php}
67 %attr(755,root,root) %{extensionsdir}/imagick.so
This page took 0.079468 seconds and 4 git commands to generate.