]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
- 0.9.1 - this is new series - NOT COMPATIBLE!! - there is a lot of new
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 %define         _modname        imagick
2 Summary:        PHP wrapper to the Image Magick Library
3 Summary(pl):    PHP-owy wrapper do biblioteki Image Magick
4 Name:           php-pecl-%{_modname}
5 Version:        0.9.1
6 Release:        1
7 License:        PHP 2.02
8 Group:          Development/Languages/PHP
9 Source0:        http://pear.php.net/get/%{_modname}-%{version}.tgz
10 URL:            http://pear.php.net/
11 BuildRequires:  ImageMagick-devel
12 BuildRequires:  php-devel
13 Requires:       php-common
14 Obsoletes:      php-imagick
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _sysconfdir     /etc/php
18 %define         extensionsdir   %{_libdir}/php
19
20 %description
21 ImageMagick is a robust collection of tools and libraries to read,
22 write, and manipulate an image in many image formats (over 68 major
23 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
24 and GIF. With ImageMagick you can create images dynamically, making it
25 suitable for Web applications. You can also resize, rotate, sharpen,
26 color reduce, or add special effects to an image and save your
27 completed work in the same or differing image format.
28
29 %description -l pl
30 ImageMagick to du¿y zestaw narzêdzi i bibliotek do odczytu, zapisu i
31 modyfikowania obrazków w wielu formatach (ponad 68 g³ównych), w tym
32 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomoc±
33 ImageMagick mo¿na dynamicznie tworzyæ obrazki, co jest przydatne w
34 aplikacjach WWW. Mo¿na je tak¿e przeskalowywaæ, obracaæ, wyostrzaæ,
35 zmniejszaæ ilo¶æ kolorów - w tym samym lub innym formacie.
36
37 %prep
38 %setup -q -c
39
40 %build
41 cd %{_modname}-%{version}
42 phpize
43 %configure \
44         --with-%{_modname}=/usr/X11R6/include/X11/
45
46 %{__make} CPPFLAGS="-DHAVE_CONFIG_H -I/usr/X11R6/include/X11/"
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{extensionsdir}
51
52 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php.ini
59
60 %preun
61 if [ "$1" = "0" ]; then
62         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php.ini
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc %{_modname}-%{version}/examples/{*.php,*.jpg,*.gif}
68 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.106044 seconds and 4 git commands to generate.