]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
5351a90a3e67e58cffe111972ecd6d5a379c36ae
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname         imagick
7 %define         status          stable
8 %define         pre             RC1
9 Summary:        %{modname} - PHP wrapper to the Image Magick Library
10 Summary(pl.UTF-8):      %{modname} - PHP-owy wrapper do biblioteki Image Magick
11 Name:           %{php_name}-pecl-%{modname}
12 Version:        3.4.3
13 Release:        0.%{pre}.1
14 License:        PHP 3.01
15 Group:          Development/Languages/PHP
16 Source0:        http://pecl.php.net/get/%{modname}-%{version}%{pre}.tgz
17 # Source0-md5:  32042fc3043f013047927de21ff15a47
18 Patch0:         skip_version_check.patch
19 URL:            http://pecl.php.net/package/imagick/
20 BuildRequires:  %{php_name}-devel >= 4:5.3
21 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  re2c
24 BuildRequires:  rpmbuild(macros) >= 1.650
25 %if %{with tests}
26 BuildRequires:  %{php_name}-cli
27 BuildRequires:  %{php_name}-pcre
28 BuildRequires:  %{php_name}-spl
29 BuildRequires:  ImageMagick-coder-jpeg
30 BuildRequires:  ImageMagick-coder-png
31 BuildRequires:  ImageMagick-coder-tiff
32 %endif
33 %{?requires_php_extension}
34 Requires(triggerpostun):        sed >= 4.0
35 Requires:       %{php_name}-spl
36 Suggests:       ImageMagick-coder-jpeg
37 Suggests:       ImageMagick-coder-png
38 Suggests:       ImageMagick-coder-tiff
39 Provides:       php(imagick) = %{version}
40 Obsoletes:      php-pecl-imagick < 3.1.2-2
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 ImageMagick is a robust collection of tools and libraries to read,
45 write, and manipulate an image in many image formats (over 68 major
46 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
47 and GIF. With ImageMagick you can create images dynamically, making it
48 suitable for Web applications. You can also resize, rotate, sharpen,
49 color reduce, or add special effects to an image and save your
50 completed work in the same or differing image format.
51
52 In PECL status of this package is: %{status}.
53
54 %description -l pl.UTF-8
55 ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
56 modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
57 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
58 ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
59 aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
60 zmniejszać ilość kolorów - w tym samym lub innym formacie.
61
62 To rozszerzenie ma w PECL status: %{status}.
63
64 %prep
65 %setup -qc
66 mv %{modname}-%{version}%{pre}/* .
67 %patch0 -p1
68
69 xfail() {
70         t=$1
71         cat >> $t <<-EOF
72
73         --XFAIL--
74         Skip
75         EOF
76 }
77 Test() {
78         nf=$(eval echo \$$#)
79         t=$nf; t=${t#\[}; t=${t%\]}
80         xfail $t
81 }
82 # skip failing tests
83 Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
84 Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
85 Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
86 Test ImagickDraw, setFontFamily [tests/207_ImagickDraw_setFontFamily_basic.phpt]
87 Test ImagickDraw, setFontStretch [tests/208_ImagickDraw_setFontStretch_basic.phpt]
88 Test ImagickDraw, setFontWeight [tests/209_ImagickDraw_setFontWeight_basic.phpt]
89 Test ImagickDraw, setFontStyle [tests/210_ImagickDraw_setFontStyle_basic.phpt]
90 Test ImagickDraw, setGravity [tests/212_ImagickDraw_setGravity_basic.phpt]
91 Test ImagickDraw, setTextAlignment [tests/222_ImagickDraw_setTextAlignment_basic.phpt]
92 Test ImagickDraw, setTextAntialias [tests/223_ImagickDraw_setTextAntialias_basic.phpt]
93 Test ImagickDraw, setTextUnderColor [tests/224_ImagickDraw_setTextUnderColor_basic.phpt]
94 Test ImagickDraw, setTextDecoration [tests/225_ImagickDraw_setTextDecoration_basic.phpt]
95 Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
96 Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
97 Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
98 Test Imagick, Imagick::exportImagePixels [tests/256_Imagick_exportImagePixels_basic.phpt]
99 Test ImagickDraw, getTextDirection [tests/264_ImagickDraw_getTextDirection_basic.phpt]
100 Test ImagickDraw, getFontResolution [tests/266_ImagickDraw_getFontResolution_basic.phpt]
101 %ifarch x32
102 # Fail on 7.0
103 Test Imagick, quantizeImage [tests/101_Imagick_quantizeImage_basic.phpt]
104 Test Imagick, uniqueImageColors [tests/163_Imagick_uniqueImageColors_basic.phpt]
105 Test Tutorial, deconstructGif [tests/237_Tutorial_deconstructGif_basic.phpt]
106 Test ImagickPixelIterator, setIteratorRow [tests/251_ImagickPixelIterator_setIteratorRow_basic.phpt]
107 %endif
108
109 %build
110 phpize
111 %configure \
112         php_cv_cc_dashr=false
113
114 %{__make} \
115         CFLAGS_CLEAN="%{rpmcflags}"
116
117 %if %{with tests}
118 %{__php} -n -q \
119         -d extension_dir=modules \
120         -d extension=%{php_extensiondir}/pcre.so \
121         -d extension=%{php_extensiondir}/spl.so \
122         -d extension=%{modname}.so \
123         -m > modules.log
124 grep %{modname} modules.log
125
126 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
127 %{__make} test \
128         PHP_EXECUTABLE=%{__php} \
129         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl" \
130 %endif
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
135 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
136 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
137 ; Enable %{modname} extension module
138 extension=%{modname}.so
139 EOF
140 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post
146 %php_webserver_restart
147
148 %postun
149 if [ "$1" = 0 ]; then
150         %php_webserver_restart
151 fi
152
153 %triggerpostun -- %{name} < 0.9.11-2.1
154 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
155
156 %files
157 %defattr(644,root,root,755)
158 %doc CREDITS
159 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
160 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
161 %{_examplesdir}/%{name}-%{version}
This page took 0.056897 seconds and 2 git commands to generate.