]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
- php 5.5 rebuild
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         imagick
3 %define         status          stable
4 Summary:        %{modname} - PHP wrapper to the Image Magick Library
5 Summary(pl.UTF-8):      %{modname} - PHP-owy wrapper do biblioteki Image Magick
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        3.1.2
8 Release:        2
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  f2fd71b026debe056e0ec8d76c2ffe94
13 Patch0:         ImageMagick-6.8.patch
14 URL:            http://pecl.php.net/package/imagick/
15 BuildRequires:  %{php_name}-devel >= 3:5.1.3
16 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
17 BuildRequires:  rpmbuild(macros) >= 1.650
18 %{?requires_php_extension}
19 Requires(triggerpostun):        sed >= 4.0
20 Requires:       php(core) >= 5.0.4
21 Suggests:       ImageMagick-coder-jpeg
22 Suggests:       ImageMagick-coder-png
23 Suggests:       ImageMagick-coder-tiff
24 Provides:       php(imagick)
25 Obsoletes:      php-imagick
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 ImageMagick is a robust collection of tools and libraries to read,
30 write, and manipulate an image in many image formats (over 68 major
31 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
32 and GIF. With ImageMagick you can create images dynamically, making it
33 suitable for Web applications. You can also resize, rotate, sharpen,
34 color reduce, or add special effects to an image and save your
35 completed work in the same or differing image format.
36
37 In PECL status of this package is: %{status}.
38
39 %description -l pl.UTF-8
40 ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
41 modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
42 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
43 ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
44 aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
45 zmniejszać ilość kolorów - w tym samym lub innym formacie.
46
47 To rozszerzenie ma w PECL status: %{status}.
48
49 %prep
50 %setup -q -c
51 mv %{modname}-%{version}/* .
52 %patch0 -p1
53
54 %build
55 phpize
56 %configure \
57         php_cv_cc_dashr=false
58
59 %{__make} \
60         CFLAGS_CLEAN="%{rpmcflags}"
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
65 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
66 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
67 ; Enable %{modname} extension module
68 extension=%{modname}.so
69 EOF
70 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 %php_webserver_restart
77
78 %postun
79 if [ "$1" = 0 ]; then
80         %php_webserver_restart
81 fi
82
83 %triggerpostun -- %{name} < 0.9.11-2.1
84 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
85
86 %files
87 %defattr(644,root,root,755)
88 %doc CREDITS
89 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
90 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
91 %{_examplesdir}/%{name}-%{version}
This page took 0.032313 seconds and 3 git commands to generate.