]> git.pld-linux.org Git - packages/php-pecl-archive.git/commitdiff
support building for multiple php versions
authorElan Ruusamäe <glen@delfi.ee>
Fri, 21 Jun 2013 17:18:24 +0000 (20:18 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 21 Jun 2013 17:18:24 +0000 (20:18 +0300)
php-pecl-archive.spec

index abd4b53b7cb1476686f0bda49b45a5252158433c..5bf7c1a26d2ed37d683a0a4fa181f6e9d0f97f5f 100644 (file)
@@ -1,43 +1,43 @@
-%define                _modname        archive
-%define                _status         beta
-Summary:       %{_modname} - manipulate tar/cpio archives
-Summary(pl.UTF-8):     %{_modname} - obróbka archiwów tar/cpio
-Name:          php-pecl-%{_modname}
+%define                php_name        php%{?php_suffix}
+%define                modname archive
+%define                status          beta
+Summary:       %{modname} - manipulate tar/cpio archives
+Summary(pl.UTF-8):     %{modname} - obróbka archiwów tar/cpio
+Name:          %{php_name}-pecl-%{modname}
 Version:       0.2
 Release:       14
 License:       PHP 3.01
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: 1b121440b2c460b2a1af46e31f23e46e
-Patch0:                %{name}-php52.patch
+Patch0:                php-pecl-%{modname}-php52.patch
 URL:           http://pecl.php.net/package/archive/
+BuildRequires: %{php_name}-devel >= 3:5.0.0
 BuildRequires: libarchive-devel
-BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.344
+BuildRequires: rpmbuild(macros) >= 1.650
 %{?requires_php_extension}
 Requires:      php(core) >= 5.0.4
-Obsoletes:     php-pear-%{_modname}
+Obsoletes:     php-pear-%{modname}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 archive extension allows to read and write tar and cpio archives using
 libarchive.
 
-In PECL status of this extension is: %{_status}.
+In PECL status of this extension is: %{status}.
 
 %description -l pl.UTF-8
 Rozszerzenie archive pozwala na odczyt i zapis archiwów tar oraz cpio
 przy użyciu biblioteki libarchive.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
-cd %{_modname}-%{version}
+%setup -qc
+mv %{modname}-%{version}/* .
 %patch0 -p0
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
@@ -45,11 +45,10 @@ phpize
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
-
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
@@ -65,6 +64,6 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/{API.txt,CREDITS,tests}
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%doc API.txt CREDITS tests
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.074376 seconds and 4 git commands to generate.