]> git.pld-linux.org Git - packages/php-pecl-adodb.git/commitdiff
- php5.3 compile fix from gentoo; rel 2 auto/th/php-pecl-adodb-5.0.4-3
authorElan Ruusamäe <glen@delfi.ee>
Mon, 19 Nov 2012 10:01:12 +0000 (12:01 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 19 Nov 2012 10:01:12 +0000 (12:01 +0200)
php-pecl-adodb.spec
php53.patch [new file with mode: 0644]

index 9c3178480d5ff66e10b826bd974dd7113361cf46..5ce40153ce3e6a3fe6be92bf65accbfa8e81070c 100644 (file)
@@ -3,18 +3,19 @@
 Summary:       ADOdb PHP extension
 Name:          php-pecl-%{modname}
 Version:       5.0.4
-Release:       2
+Release:       3
 License:       BSD
 Group:         Development/Languages/PHP
 Source0:       http://phplens.com/lens/dl/adodb-ext-%{ver}.zip
 # Source0-md5: 4efb3fc1f5a347f20be9222885779688
+Patch0:                php53.patch
 URL:           http://adodb.sourceforge.net/
 BuildRequires: php-devel >= 3:5.0.0
 BuildRequires: rpmbuild(macros) >= 1.553
 BuildRequires: sed >= 4.0
 BuildRequires: unzip
 %{?requires_php_extension}
-Requires:      php-common >= 4:5.0.4
+Requires:      php(core) >= 5.0.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -25,7 +26,8 @@ installed and use it automatically.
 %prep
 %setup -q -c
 mv %{modname}-%{ver}/* .
-%undos README.txt
+%undos -f c,txt
+%patch0 -p1
 
 %build
 phpize
diff --git a/php53.patch b/php53.patch
new file mode 100644 (file)
index 0000000..0cbce9b
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/adodb.c  2005-11-25 20:00:56.000000000 +0100
++++ b/adodb.c  2011-03-06 22:27:06.000000000 +0100
+@@ -159,11 +159,7 @@
+ static void adodb_init_zval(zval *v, char *s)
+ {
+-      v->type = IS_STRING;
+-      v->value.str.val = s;
+-      v->value.str.len = strlen(s);
+-      v->is_ref = 0;
+-      v->refcount = 1;
++      ZVAL_STRING(v, s, 0);
+ }
+ /* {{{ PHP_MINIT_FUNCTION
+@@ -277,7 +273,7 @@
+       fci.function_table = EG(function_table);
+       fci.function_name = &adodb_zvals[zval_ocifetch];
+       fci.symbol_table = NULL;
+-      fci.object_pp = NULL;
++      /* fci.object_pp = NULL; */
+       fci.retval_ptr_ptr = &retval;
+       fci.param_count = 2;
+       fci.params = &params[1];
This page took 0.099038 seconds and 4 git commands to generate.