]> git.pld-linux.org Git - packages/php-pear.git/blobdiff - php-pear.spec
v1.4: add symfony dirs
[packages/php-pear.git] / php-pear.spec
index cc1ff27bc9db01ed2939c9c831254f69574542cf..1d6cc3ccd29141c4de83ea9f60b3d911900142f5 100644 (file)
@@ -1,7 +1,7 @@
 Summary:       PEAR - PHP Extension and Application Repository
 Summary(pl.UTF-8):     PEAR - rozszerzenie PHP i repozytorium aplikacji
 Name:          php-pear
-Version:       1.3.15
+Version:       1.4
 Release:       1
 Epoch:         4
 License:       Public Domain
@@ -28,6 +28,8 @@ Source17:     channel-twig.xml
 Source18:      channel-zz.xml
 Source19:      channel-theseer.xml
 Source20:      channel-indeyets.xml
+Source21:      channel-phpdoc.xml
+Source22:      channel-bartlett.xml
 BuildRequires: /usr/bin/php
 BuildRequires: php-pear-PEAR >= 1:1.9.0
 BuildRequires: rpmbuild(macros) >= 1.570
@@ -37,7 +39,7 @@ Conflicts:    php-pear-PEAR < 1:1.7.2-10
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                __reg_provides  php %{SOURCE0}
+%define                __reg_provides  %{__php} %{SOURCE0}
 
 # find channel provides
 %define                _use_internal_dependency_generator 0
@@ -81,6 +83,8 @@ done
 install -d $RPM_BUILD_ROOT%{php_pear_dir}/{.registry,bin,data,tests}
 cp -a pear/.??* $RPM_BUILD_ROOT%{php_pear_dir}
 
+install -d $RPM_BUILD_ROOT%{php_data_dir}/Symfony/{Bridge,Component}
+
 while read dir; do
        install -d $RPM_BUILD_ROOT$dir
 done <<EOF
@@ -145,7 +149,11 @@ check_channel_dirs() {
        find $RPM_BUILD_ROOT%{php_pear_dir} | LC_ALL=C sort > $installed
        sed -i -re "s#^$RPM_BUILD_ROOT%{php_pear_dir}/?##" $installed
 
-       rpm -qpl %{_rpmdir}/$RPMFILE |  LC_ALL=C sort > $rpmfiles
+       rpm -qpl %{_rpmdir}/$RPMFILE | LC_ALL=C sort > $rpmfiles
+
+       # temp hack to exclude non-pear dirs
+       %{__sed} -i -e 's#%{php_data_dir}/.*##' $rpmfiles
+
        sed -i -re "s#^%{php_pear_dir}/?##" $rpmfiles
 
        # find finds also '.', so use option -B for diff
@@ -171,6 +179,12 @@ check_channel_dirs
 %dir %{php_pear_dir}
 %{php_pear_dir}/*
 
+# other php dirs
+%dir %{php_data_dir}/Symfony
+%dir %{php_data_dir}/Symfony/Bridge
+%dir %{php_data_dir}/Symfony/Component
+
+# PEAR state files
 %ghost %{php_pear_dir}/.depdblock
 %ghost %{php_pear_dir}/.depdb
 %ghost %{php_pear_dir}/.filemap
@@ -275,3 +289,11 @@ check_channel_dirs
 %{php_pear_dir}/.channels/.alias/indeyets.txt
 %{php_pear_dir}/.channels/pear.indeyets.ru.reg
 %{php_pear_dir}/.registry/.channel.pear.indeyets.ru
+
+%{php_pear_dir}/.channels/.alias/phpdoc.txt
+%{php_pear_dir}/.channels/pear.phpdoc.org.reg
+%{php_pear_dir}/.registry/.channel.pear.phpdoc.org
+
+%{php_pear_dir}/.channels/.alias/bartlett.txt
+%{php_pear_dir}/.channels/bartlett.laurent-laville.org.reg
+%{php_pear_dir}/.registry/.channel.bartlett.laurent-laville.org
This page took 0.073629 seconds and 4 git commands to generate.