]> git.pld-linux.org Git - packages/php-dirs.git/blob - php-dirs.spec
cf0b01cf47946e234571149a612b3db8980b1cb4
[packages/php-dirs.git] / php-dirs.spec
1 # TODO
2 # - move tmpwatch S: to php-session package (as session files file storage no
3 #   longer can cleanup itself due dir perms)
4 Summary:        Common dirs for different PHP versions
5 Summary(pl.UTF-8):      Wspólne katalogi dla różnych wersji PHP
6 Name:           php-dirs
7 Version:        1.5
8 Release:        2
9 License:        GPL
10 Group:          Base
11 Source0:        php-session.sh
12 Source1:        %{name}.tmpfiles
13 BuildRequires:  rpmbuild(macros) >= 1.644
14 Requires(postun):       /usr/sbin/groupdel
15 Requires(pre):  /usr/bin/getgid
16 Requires(pre):  /usr/sbin/groupadd
17 Suggests:       tmpwatch
18 Provides:       group(http)
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Common directories for PHP version 4 and version 5.
24
25 %description -l pl.UTF-8
26 Wspólne katalogi dla PHP w wersji 4 oraz 5.
27
28 %prep
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 install -d $RPM_BUILD_ROOT{%{php_data_dir}/tests,/etc/cron.hourly,/var/{cache,log,run}/php,/var/log/archive/php} \
33         $RPM_BUILD_ROOT%{_docdir}/phpdoc \
34         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
35
36 install -p %{SOURCE0} $RPM_BUILD_ROOT/etc/cron.hourly
37 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %pre
43 %groupadd -g 51 http
44
45 %postun
46 if [ "$1" = "0" ]; then
47         %groupremove http
48 fi
49
50 %files
51 %defattr(644,root,root,755)
52 %{systemdtmpfilesdir}/%{name}.conf
53 %attr(755,root,root) %{_sysconfdir}/cron.hourly/php-session.sh
54 %dir %{php_data_dir}
55 %dir %{php_data_dir}/tests
56 %dir %{_docdir}/phpdoc
57 %attr(775,root,http) %dir %verify(not group mode) /var/log/php
58 %attr(770,root,root) %dir %verify(not group mode) /var/log/archive/php
59 # no +r, so only predictable names can be used. currently php-soap wsdl cache is there
60 %attr(730,root,http) %dir %verify(not group mode) /var/cache/php
61 # http needs only x for directory (otherwise it knows session file
62 # names and can read it contents)
63 # keep o+x for fcgi.sock (lighttpd)
64 %attr(731,root,http) %dir %verify(not group mode) /var/run/php
This page took 0.051454 seconds and 2 git commands to generate.