]> git.pld-linux.org Git - packages/php-dirs.git/blame - php-dirs.spec
- ver 1.8. use ls to find possible php commands
[packages/php-dirs.git] / php-dirs.spec
CommitLineData
0f165b1d
ER
1# TODO
2# - move tmpwatch S: to php-session package (as session files file storage no
3# longer can cleanup itself due dir perms)
8c92a476 4# - https://fedorahosted.org/tmpwatch/ticket/7 is implemented in tmpwatch-2.9.16, see 3467603 todo
0bcfd373
ER
5Summary: Common dirs for PHP
6Summary(pl.UTF-8): Wspólne katalogi dla PHP
a8668484 7Name: php-dirs
5e404486 8Version: 1.8
0bcfd373 9Release: 1
a8668484
ER
10License: GPL
11Group: Base
ee96ae59 12Source0: php-session.sh
56b17828 13Source1: %{name}.tmpfiles
21e70d86 14Source2: crontab
05ac7df2 15BuildRequires: rpmbuild(macros) >= 1.644
31b41079
ER
16Requires(postun): /usr/sbin/groupdel
17Requires(pre): /usr/bin/getgid
18Requires(pre): /usr/sbin/groupadd
c29d80f3 19Suggests: tmpwatch
0bcfd373 20Conflicts: php-pear < 4:1.4-2
31b41079 21Provides: group(http)
a8668484
ER
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
21e70d86
ER
25%define _libexecdir %{_prefix}/lib
26
a8668484 27%description
0bcfd373 28Common directories for PHP.
a8668484 29
f4cc5fb9 30%description -l pl.UTF-8
0bcfd373 31Wspólne katalogi dla PHP.
cce45ac9 32
a8668484
ER
33%prep
34
35%install
36rm -rf $RPM_BUILD_ROOT
21e70d86 37install -d $RPM_BUILD_ROOT{/etc/cron.d,/var/{cache,log,run}/php,/var/log/archive/php} \
56b17828 38 $RPM_BUILD_ROOT%{_docdir}/phpdoc \
21e70d86 39 $RPM_BUILD_ROOT%{_libexecdir} \
05ac7df2 40 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
56b17828 41
21e70d86 42install -p %{SOURCE0} $RPM_BUILD_ROOT%{_libexecdir}
05ac7df2 43cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
21e70d86 44cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/php-session
a8668484 45
0bcfd373
ER
46while read dir; do
47 install -d $RPM_BUILD_ROOT$dir
48done <<EOF
49%{php_data_dir}/tests
50%{php_data_dir}/Symfony/Bridge
51%{php_data_dir}/Symfony/Component
52EOF
53
a8668484
ER
54%clean
55rm -rf $RPM_BUILD_ROOT
56
31b41079
ER
57%pre
58%groupadd -g 51 http
59
60%postun
61if [ "$1" = "0" ]; then
62 %groupremove http
63fi
64
a8668484
ER
65%files
66%defattr(644,root,root,755)
21e70d86 67%config(noreplace) %verify(not md5 mtime size) /etc/cron.d/php-session
05ac7df2 68%{systemdtmpfilesdir}/%{name}.conf
21e70d86 69%attr(755,root,root) %{_libexecdir}/php-session.sh
0bcfd373
ER
70%{php_data_dir}
71
dea06829 72%dir %{_docdir}/phpdoc
05ac7df2 73%attr(775,root,http) %dir %verify(not group mode) /var/log/php
ec175e53 74%attr(770,root,root) %dir %verify(not group mode) /var/log/archive/php
0bcfd373 75
ebe84aa1
ER
76# no +r, so only predictable names can be used. currently php-soap wsdl cache is there
77%attr(730,root,http) %dir %verify(not group mode) /var/cache/php
0bcfd373
ER
78
79# http needs only +x for directory
80# (otherwise it knows session file names and can read it contents)
4ce953dd
ER
81# keep o+x for fcgi.sock (lighttpd)
82%attr(731,root,http) %dir %verify(not group mode) /var/run/php
This page took 0.126806 seconds and 4 git commands to generate.