]> git.pld-linux.org Git - packages/php-dbus.git/commitdiff
- new
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 20 Oct 2010 07:04:28 +0000 (07:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-dbus.spec -> 1.1

php-dbus.spec [new file with mode: 0644]

diff --git a/php-dbus.spec b/php-dbus.spec
new file mode 100644 (file)
index 0000000..2557e88
--- /dev/null
@@ -0,0 +1,76 @@
+#
+# Conditional build:
+%bcond_without tests           # build without tests
+
+%define                svnrev  1
+%define                rel             0.1
+%define                modname dbus
+Summary:       DBus binding for PHP
+Name:          php-%{modname}
+Version:       1.0
+Release:       0.svn%{svnrev}.%{rel}
+License:       New BSD License
+Group:         Development/Languages/PHP
+# revno=
+# svn co http://php-dbus.googlecode.com/svn/trunk${revno:+@$revno} php-dbus
+# tar -cjf php-dbus-$(svnversion php-dbus).tar.bz2 --exclude-vcs php-dbus
+# ../dropin php-dbus-$(svnversion php-dbus).tar.bz2
+Source0:       %{name}-%{svnrev}.tar.bz2
+# Source0-md5: bc29a6add663ae977fde560175ccf306
+URL:           http://code.google.com/p/php-dbus/
+BuildRequires: dbus-devel
+BuildRequires: php-devel >= 4:5.0.4
+BuildRequires: rpmbuild(macros) >= 1.519
+%{?requires_php_extension}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+D-Bus is a message bus system, a simple way for applications to talk
+to one another. In addition to interprocess communication, D-Bus helps
+coordinate process lifecycle; it makes it simple and reliable to code
+a "single instance" application or daemon, and to launch applications
+and daemons on demand when their services are needed.
+
+php-dbus is a binding of PHP and DBus.
+
+%prep
+%setup -qn %{name}
+
+%build
+phpize
+%configure
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
+install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
+install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
+
+%{__make} install \
+       INSTALL_ROOT=$RPM_BUILD_ROOT \
+       EXTENSION_DIR=%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
+EOF
+
+cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%php_webserver_restart
+
+%postun
+if [ "$1" = 0 ]; then
+       %php_webserver_restart
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc CREDITS EXPERIMENTAL
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
+%{_examplesdir}/%{name}-%{version}
This page took 0.078306 seconds and 4 git commands to generate.