]> git.pld-linux.org Git - packages/perl.git/commitdiff
- fix gcc error: invalid use of void expression auto/th/perl-5.18.0-7
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 9 Jun 2013 19:13:07 +0000 (21:13 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 9 Jun 2013 19:13:07 +0000 (21:13 +0200)
- rel 7

perl-invalid-void-use.patch [new file with mode: 0644]
perl.spec

diff --git a/perl-invalid-void-use.patch b/perl-invalid-void-use.patch
new file mode 100644 (file)
index 0000000..fa10785
--- /dev/null
@@ -0,0 +1,11 @@
+--- perl-5.18.0/sv.h~  2013-05-10 04:30:48.000000000 +0200
++++ perl-5.18.0/sv.h   2013-06-09 21:11:34.889499879 +0200
+@@ -330,7 +330,7 @@
+ /* this is defined in this peculiar way to avoid compiler warnings.
+  * See the <20121213131428.GD1842@iabyn.com> thread in p5p */
+ #define SvUPGRADE(sv, mt) \
+-    ((void)(SvTYPE(sv) >= (mt) || (sv_upgrade(sv, mt),1)))
++    (SvTYPE(sv) >= (mt) || (sv_upgrade(sv, mt),1))
+ #define SVf_IOK               0x00000100  /* has valid public integer value */
+ #define SVf_NOK               0x00000200  /* has valid public numeric value */
index dfc08d8d6d709fde7185d0f02adedddb692cba41..54786d5428fc477266b3075438f6fd8dfa4b1bdf 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -44,7 +44,7 @@
 %define                perl_modversion()       %([ -f %{SOURCE3} ] && awk -vp=%1 '$1 == p{m=$1; gsub(/::/, "-", m); printf("perl-%s = %s\\n", m, $3)}END{if (!m) printf("# Error looking up [%s]\\n", p)}' %{SOURCE3} || echo ERROR)
 
 %define                ver     5.18.0
-%define                rel     6
+%define                rel     7
 Summary:       Practical Extraction and Report Language (Perl)
 Summary(cs.UTF-8):     Programovací jazyk Perl
 Summary(da.UTF-8):     Programmeringssproget Perl
@@ -86,6 +86,7 @@ Patch6:               %{name}-write-permissions.patch
 Patch7:                %{name}-t-syslog.patch
 Patch8:                %{name}-fix-pointer-arithmetic.patch
 Patch9:                %{name}-switch.patch
+Patch10:       %{name}-invalid-void-use.patch
 URL:           http://dev.perl.org/perl5/
 %ifarch ppc
 # gcc 3.3.x miscompiles pp_hot.c
@@ -692,6 +693,7 @@ z biblioteki GNU gdbm.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 cat > runperl <<'EOF'
 #!/bin/sh
This page took 0.137025 seconds and 4 git commands to generate.