]> git.pld-linux.org Git - packages/perl.git/commitdiff
- specialcase ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib checking... auto/th/perl-5.18.2-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 12 Jan 2014 21:38:39 +0000 (22:38 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 12 Jan 2014 21:38:39 +0000 (22:38 +0100)
perl-modules
perl.spec

index f25746e79057afeb6e356e5ab214cac5a850ea47..dd7d206af7fe94dfde2e9aa2e8d0d5a933be5ead 100644 (file)
@@ -1,5 +1,4 @@
 # Module versions from Perl 5.18.2 distribution.
-# DO NOT REMOVE TRAILING '0' FROM Compress::Raw::* AND ExtUtils::CBuilder WITHOUT VERYFYING!
 Archive::Tar = 1.90
 Attribute::Handlers = 0.94
 CGI = 3.63
index aeb1075d681655b5f4da948c312935b94b87dc5d..a8cd80b033e3fab2ec02af21524775b8d4e6d2d4 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -911,8 +911,12 @@ for m in $(awk '!/^#/ && !/^$/{print $1}' %{SOURCE3}); do
        libnet)
                v=$(awk '/^libnet /{print $2; exit}' cpan/libnet/Changes)
                ;;
+       # special cased since do eval on VERSION
+       ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib)
+               v=$(%{__perl} -M$m -e "print version->parse(\$$m::VERSION)->numify")
+               ;;
        *)
-               v=$(%{__perl} -M$m -e "print $m->VERSION" )
+               v=$(%{__perl} -M$m -e "print \$$m::VERSION")
                ;;
        esac
        echo "$m = $v"
@@ -921,15 +925,19 @@ echo '# Non-straight named module versions from Perl %{ver} distribution.' > per
 for m in $(awk '!/^#/ && !/^$/{print $1"!"$2}' %{SOURCE4}); do
        mn="${m##*!}"
        mp="${m%%!*}"
-       v=$(%{__perl} -M$mn -e "print $mn->VERSION" )
+       case $m in
+       # special cased since do eval on VERSION
+       ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib)
+               v=$(%{__perl} -M$mn -e "print version->parse(\$$mn::VERSION)->numify")
+               ;;
+       *)
+               v=$(%{__perl} -M$mn -e "print \$$mn::VERSION")
+               ;;
+       esac
        echo "$mp       $mn = $v"
 done | LC_ALL=C sort >> perl-modules2
 
-# ExtUtils::CBuilder Compress::Raw::Bzip2 Compress::Raw::Zlib ignored due to VERSION from the loop above
-# is missing ending '0'
-grep -Ev '^([  ]*$|[;#])' %{SOURCE3} | grep -Ev 'ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib' > .mods1
-grep -Ev '^([  ]*$|[;#])' perl-modules | grep -Ev 'ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib' > .mods2
-if ! cmp -s .mods1 .mods2; then
+if ! cmp -s %{SOURCE3} perl-modules; then
        : %{SOURCE3} outdated with $(pwd)/perl-modules
        exit 1
 fi
This page took 0.136019 seconds and 4 git commands to generate.