]> git.pld-linux.org Git - packages/perl.git/commitdiff
- up to 5.18.1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 29 Aug 2013 13:49:24 +0000 (15:49 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 29 Aug 2013 13:49:24 +0000 (15:49 +0200)
perl-fix-pointer-arithmetic.patch [deleted file]
perl-modules
perl-modules2
perl.spec

diff --git a/perl-fix-pointer-arithmetic.patch b/perl-fix-pointer-arithmetic.patch
deleted file mode 100644 (file)
index 1fe93d4..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Fix pointer arithmetic overflow introduced in upstream commit 4063ade8503ac8877a02fc4eae8ebbe242b9110b,
-# which caused the following tests to fail on i486 and i686:
-# t/re/pat_rt_report_thr ........................................ FAILED at test 55
-# Failed test 55 - UTF-8 regex matches above 32k; Bug 20020630.002 at re/pat_rt_report.t line 224
-# <utf8 x 32000>; pos = 1
-# Failed test 57 - UTF-8 regex matches above 32k; Bug 20020630.002 at re/pat_rt_report.t line 224
-# <utf8 x 32768>; pos = 1
-# Failed test 59 - UTF-8 regex matches above 32k; Bug 20020630.002 at re/pat_rt_report.t line 224
-# <utf8 x 33000>; pos = 1
-diff --git a/regexec.c b/regexec.c
-index bc38839..6199677 100644
---- a/regexec.c
-+++ b/regexec.c
-@@ -6662,7 +6662,7 @@ S_regrepeat(pTHX_ regexp *prog, char **startposp, const regnode *p,
-     scan = *startposp;
-     if (max == REG_INFTY)
-       max = I32_MAX;
--    else if (! utf8_target && scan + max < loceol)
-+    else if (! utf8_target && max < loceol - scan)
-       loceol = scan + max;
-     /* Here, for the case of a non-UTF-8 target we have adjusted <loceol> down
-@@ -6711,7 +6711,7 @@ S_regrepeat(pTHX_ regexp *prog, char **startposp, const regnode *p,
-           scan = loceol;
-       break;
-     case CANY:  /* Move <scan> forward <max> bytes, unless goes off end */
--        if (utf8_target && scan + max < loceol) {
-+        if (utf8_target && max < loceol - scan) {
-             /* <loceol> hadn't been adjusted in the UTF-8 case */
-             scan +=  max;
-@@ -6730,7 +6730,7 @@ S_regrepeat(pTHX_ regexp *prog, char **startposp, const regnode *p,
-          * can use UTF8_IS_INVARIANT() even if the pattern isn't UTF-8, as it's
-          * true iff it doesn't matter if the argument is in UTF-8 or not */
-         if (UTF8_IS_INVARIANT(c) || (! utf8_target && ! is_utf8_pat)) {
--            if (utf8_target && scan + max < loceol) {
-+            if (utf8_target && max < loceol - scan) {
-                 /* We didn't adjust <loceol> because is UTF-8, but ok to do so,
-                  * since here, to match at all, 1 char == 1 byte */
-                 loceol = scan + max;
-@@ -6910,7 +6910,7 @@ S_regrepeat(pTHX_ regexp *prog, char **startposp, const regnode *p,
-         /* FALLTHROUGH */
-     case POSIXA:
--        if (utf8_target && scan + max < loceol) {
-+        if (utf8_target && max < loceol - scan) {
-             /* We didn't adjust <loceol> at the beginning of this routine
-              * because is UTF-8, but it is actually ok to do so, since here, to
index 144f20f19a5fca0830eb6d6b8bf779075c7dc8a9..33f099744984eb1670bcada9dd4ded5e43228236 100644 (file)
@@ -1,19 +1,19 @@
-# Module versions from Perl 5.18.0 distribution.
+# Module versions from Perl 5.18.1 distribution.
 Archive::Tar = 1.90
 Attribute::Handlers = 0.94
 CGI = 3.63
 CPAN = 2.00
 CPAN::Meta = 2.120921
 CPAN::Meta::YAML = 0.008
-Compress::Raw::Bzip2 = 2.060
-Compress::Raw::Zlib = 2.060
+Compress::Raw::Bzip2 = 2.06
+Compress::Raw::Zlib = 2.06
 Devel::PPPort = 3.20
 Devel::Peek = 1.11
 Digest = 1.17
 Digest::MD5 = 2.52
-Digest::SHA = 5.84
+Digest::SHA = 5.84_01
 Encode = 2.49
-ExtUtils::CBuilder = 0.280210
+ExtUtils::CBuilder = 0.28021
 ExtUtils::Command = 1.17
 ExtUtils::Embed = 1.30
 ExtUtils::Install = 1.59
@@ -43,7 +43,7 @@ Math::Complex = 1.59
 Math::Trig = 1.23
 Memoize = 1.03
 Module::Build = 0.4003
-Module::CoreList = 2.90
+Module::CoreList = 2.96
 Module::Load = 0.24
 Module::Load::Conditional = 0.54
 Module::Metadata = 1.000011
index 68d668318860a3023c0f8e665e6fc54d294c14d0..1473de8f9d546691f0597887b16651bbed0fc1a4 100644 (file)
@@ -1,4 +1,4 @@
-# Non-straight named module versions from Perl 5.18.0 distribution.
+# Non-straight named module versions from Perl 5.18.1 distribution.
 IO-Compress    IO::Compress::Base = 2.060
 PathTools      File::Spec = 3.40
 Scalar-List-Utils      List::Util = 1.27
index 07b86cda8166655f98a904d8da4be685aec63c13..11c4bf31c0798a267b3ca8ca3ccee81285d9f4b0 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -44,8 +44,8 @@
 %define                perl_mod2verrel()       %([ -f %{SOURCE4} ] && awk -vp=%1 -vr=%2 '$1 == p { print $4"-"r }' %{SOURCE4} || echo ERROR)
 %define                perl_mod2version()      %([ -f %{SOURCE4} ] && awk -vp=%1 '$1 == p { m=$2; printf("perl-%s = %s\\n", p, $4)}END{if (!m) printf("# Error looking up [%s]\\n", p) }' %{SOURCE4} || echo ERROR)
 
-%define                ver     5.18.0
-%define                rel     11
+%define                ver     5.18.1
+%define                rel     1
 Summary:       Practical Extraction and Report Language (Perl)
 Summary(cs.UTF-8):     Programovací jazyk Perl
 Summary(da.UTF-8):     Programmeringssproget Perl
@@ -74,7 +74,7 @@ Epoch:                1
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/src/5.0/%{name}-%{ver}.tar.gz
-# Source0-md5: 197ce31e84936bc0a83b03b2ee714cff
+# Source0-md5: 304cb5bd18e48c44edd6053337d3386d
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: de47d7893f49ad7f41ba69c78511c0db
 Source2:       %{name}.prov
@@ -86,7 +86,7 @@ Patch4:               %{name}-test-noproc.patch
 Patch5:                %{name}_585-microperl_uconfig.patch
 Patch6:                %{name}-write-permissions.patch
 Patch7:                %{name}-t-syslog.patch
-Patch8:                %{name}-fix-pointer-arithmetic.patch
+
 Patch9:                %{name}-switch.patch
 Patch10:       %{name}-invalid-void-use.patch
 URL:           http://dev.perl.org/perl5/
@@ -714,7 +714,7 @@ z biblioteki GNU gdbm.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
+
 %patch9 -p1
 %patch10 -p1
 
This page took 0.178736 seconds and 4 git commands to generate.