]> git.pld-linux.org Git - packages/perl.git/commitdiff
cleanups of too much c-p
authorElan Ruusamäe <glen@delfi.ee>
Wed, 22 Apr 2015 09:27:33 +0000 (12:27 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 22 Apr 2015 09:27:33 +0000 (12:27 +0300)
perl.spec

index 182ec502a0e72b542b9bb60fb2535851a4ad39e6..0b8f0043e60cccab4cb997d08dcffc811eb5e195 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -903,7 +903,7 @@ echo '# Module versions from Perl %{ver} distribution.' > perl-modules
 for m in $(awk '!/^#/ && !/^$/{print $1}' %{SOURCE3}); do
        case $m in
        libnet)
-               v=$(awk '/VERSION/ {print $3; exit}' cpan/libnet/Makefile.PL | tr -d \',)
+               v=$(awk '/VERSION/ {print $3; exit}' cpan/libnet/Makefile.PL | tr -d "',")
                ;;
        # special cased since do eval on VERSION
        ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib)
@@ -915,15 +915,12 @@ for m in $(awk '!/^#/ && !/^$/{print $1}' %{SOURCE3}); do
        esac
        echo "$m = $v"
 done | LC_ALL=C sort >> perl-modules
+
 echo '# Non-straight named module versions from Perl %{ver} distribution.' > perl-modules2
 for m in $(awk '!/^#/ && !/^$/{print $1"!"$2}' %{SOURCE4}); do
        mn="${m##*!}"
        mp="${m%%!*}"
        case $m in
-       # special cased since do eval on VERSION
-       ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib)
-               v=$(%{__perl} -M$mn -e "print version->parse(\$$mn::VERSION)->numify")
-               ;;
        *)
                v=$(%{__perl} -M$mn -e "print \$$mn::VERSION")
                ;;
This page took 0.118319 seconds and 4 git commands to generate.