]> git.pld-linux.org Git - packages/perl.git/commitdiff
- fix Getopt::Long version detection auto/th/perl-5.28.0-4
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 31 Aug 2018 16:20:24 +0000 (18:20 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 31 Aug 2018 16:20:24 +0000 (18:20 +0200)
- rel 4

perl-modules
perl.spec

index 7be7d8f5394dcab3617e6d54715c0c578459dc9b..e7e58abb74b758531f6c0bba1cd5623c1f46c95e 100644 (file)
@@ -25,6 +25,7 @@ File::Temp = 0.2304
 Filter::Simple = 0.95
 FindBin = 1.51
 GDBM_File = 1.17
+Getopt::Long = 2.50
 Hash::Util = 0.22
 I18N::LangTags = 0.43
 IO = 1.39
index 4166789238d7f74ad3917a3b0517db30c59e9d46..1840d5b4955250e5a70ce32a805627e588e25820 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -44,7 +44,7 @@
 %define                perl_mod2version()      %([ -f %{SOURCE4} ] && awk -vp=%1 '$1 == p { m=$2; printf("perl-%s = %s\\n", p, $4)}END{if (!m) printf("# Error looking up [%s]\\n", p) }' %{SOURCE4} || echo ERROR)
 
 %define                ver     5.28.0
-%define                rel     3
+%define                rel     4
 Summary:       Practical Extraction and Report Language (Perl)
 Summary(cs.UTF-8):     Programovací jazyk Perl
 Summary(da.UTF-8):     Programmeringssproget Perl
@@ -943,6 +943,10 @@ for m in $(awk '!/^#/ && !/^$/{print $1}' %{SOURCE3}); do
        ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib)
                v=$(%{__perl} -M$m -e "print version->parse(\$$m::VERSION)->numify")
                ;;
+       # this module has VERSION encoded as int in a way that it loses trailing 0
+       Getopt::Long)
+               v=$(%{__perl} -M$m -e "print \$$m::VERSION_STRING")
+               ;;
        *)
                v=$(%{__perl} -M$m -e "print \$$m::VERSION")
                ;;
This page took 0.030838 seconds and 4 git commands to generate.