]> git.pld-linux.org Git - packages/perl-Type-Tiny.git/blame - perl-Type-Tiny.spec
- up to 1.002001
[packages/perl-Type-Tiny.git] / perl-Type-Tiny.spec
CommitLineData
42889f1a
AM
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Type
6%define pnam Tiny
7%include /usr/lib/rpm/macros.perl
8Summary: Type::Tiny - tiny, yet Moo(se)-compatible type constraint
9Name: perl-Type-Tiny
afbc0044 10Version: 1.002001
42889f1a
AM
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-authors/id/T/TO/TOBYINK/Type-Tiny-%{version}.tar.gz
afbc0044 16# Source0-md5: 9a529fd6524d75e6cbfeb33df5237db9
42889f1a
AM
17URL: http://search.cpan.org/dist/Type-Tiny/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-Exporter-Tiny >= 0.026
22%endif
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Type::Tiny is a tiny class for creating Moose-like type constraint
28objects which are compatible with Moo, Moose and Mouse.
29
30Maybe now we won't need to have separate MooseX, MouseX and MooX
31versions of everything? We can but hope...
32
33This documents the internals of Type::Tiny. Type::Tiny::Manual is a
34better starting place if you're new.
35
36%prep
37%setup -q -n %{pdir}-%{pnam}-%{version}
38
39%build
40%{__perl} Makefile.PL \
41 INSTALLDIRS=vendor
42%{__make}
43
44%{?with_tests:%{__make} test}
45
46%install
47rm -rf $RPM_BUILD_ROOT
48
49%{__make} pure_install \
50 DESTDIR=$RPM_BUILD_ROOT
51
52install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
60%doc Changes CREDITS INSTALL NEWS README TODO
61%{perl_vendorlib}/Devel/TypeTiny
62%{perl_vendorlib}/Error/TypeTiny.pm
63%{perl_vendorlib}/Error/TypeTiny
64%{perl_vendorlib}/Eval/TypeTiny.pm
65%{perl_vendorlib}/Reply/Plugin/TypeTiny.pm
66%{perl_vendorlib}/Test/TypeTiny.pm
67%{perl_vendorlib}/Type
68%{perl_vendorlib}/Types
69%{_mandir}/man3/*
70%{_examplesdir}/%{name}-%{version}
This page took 0.107076 seconds and 4 git commands to generate.