]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blobdiff - perl-Test-Simple.spec
- updated to 1.302183
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
index 1478cd4b9f33163e56a40fd483e946f790f22a38..11f2cfa97262e3e75580e62cd9310b538bdd8b60 100644 (file)
@@ -2,39 +2,47 @@
 # Conditional build:
 %bcond_without tests   # do not perform "make test"
 #
-%include       /usr/lib/rpm/macros.perl
 %define                pdir    Test
 %define                pnam    Simple
 Summary:       Test::Simple - basic utilities for writing tests
-Summary(pl):   Test::Simple - podstawowe narzêdzia do pisania testów
+Summary(pl.UTF-8):     Test::Simple - podstawowe narzędzia do pisania testów
 Name:          perl-Test-Simple
-Version:       0.64
+# NOTE: perl 5.32 provides 1.302175
+Version:       1.302183
+%define        fver    %(echo %{version} | tr -d _)
 Release:       1
 # same as perl
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: e22dcd4f06eed7b389f2bd0d17ed4dc1
-URL:           http://search.cpan.org/dist/Test-Simple/
+Source0:       http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
+# Source0-md5: b9bd0b573de649893dbd1d746691cd0a
+URL:           https://metacpan.org/release/Test-Simple
+%{?with_tests:BuildRequires:   perl-Test-Harness >= 2.03}
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
-Provides:      perl-Test-Builder-Tester = 1.04
-Obsoletes:     perl-Test-Builder-Tester = 0:1.01
+BuildRequires: rpmbuild(macros) >= 1.745
+# see lib/Test/Builder/Tester.pm /VERSION
+Provides:      perl-Test-Builder-Tester = %{version}
+# see lib/Test/Tester.pm /VERSION
+Provides:      perl-Test-Tester = %{version}
+# see lib/Test/use/ok.pm /VERSION
+Provides:      perl-Test-use-ok = %{version}
+# obsolete only versions up to last standalone release to avoid obsoleting perl-modules
+# Test::Builder::Tester 1.01
+# Test::Tester 0.109
+# Test::use::ok 0.11
+Obsoletes:     perl-Test-Builder-Tester < 1.02
+Obsoletes:     perl-Test-Tester < 0.110
+Obsoletes:     perl-Test-use-ok < 0.12
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# false requires found by rpm 4.0.2
-%if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
-%define                _noautoreq      'perl(threads)' 'perl(threads::shared)'
-%else
-Requires:      perl(threads)
-Requires:      perl(threads::shared)
-%endif
+%define                _noautoreq_perl threads threads::shared
 
 %description
 AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
 me to Detroit, but don't make me write tests!
- -- perldoc Test::Tutorial
  -- perldoc Test::Tutorial
 
 Test::Simple is an extremely simple, extremely basic module for
 writing tests suitable for CPAN modules and other pursuits. If you
@@ -47,27 +55,26 @@ facilities to skip tests, test future features and compare complicated
 data structures. While you can do almost anything with a simple "ok()"
 function, it doesn't provide good diagnostic output.
 
-%description -l pl
+%description -l pl.UTF-8
 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
-mnie, biczujcie mnie, wy¶lijcie do Detroit, ale nie ka¿cie pisaæ
-testów!
- -- perldoc Test::Tutorial
+mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
+testów!
  -- perldoc Test::Tutorial
 
-Test::Simple jest bardzo prostym, bardzo podstawowym modu³em do
-pisania testów pasuj±cych do modu³ów CPAN i innych. Do bardziej
-skomplikowanych testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego
+Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
+pisania testów pasujących do modułów CPAN i innych. Do bardziej
+skomplikowanych testów lepiej używać modułu Test::More (zastępującego
 ten).
 
-Celem Test::More jest dostarczenie szerokiego zakresu narzêdzi do
-testowania. Ró¿ne sposoby powiedzenia "ok" z lepsz± diagnostyk±,
-u³atwienia przy pomijaniu testów, testowaniu przysz³ych mo¿liwo¶ci i
-porównywaniu skomplikowanych struktur danych. O ile mo¿na zrobiæ
-prawie wszystko prost± funkcj± "ok()", nie daje ona dobrego wyj¶cia
+Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
+testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
+ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
+porównywaniu skomplikowanych struktur danych. O ile można zrobić
+prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
 diagnostycznego.
 
 %prep
-%setup -q -n %{pdir}-%{pnam}-%{version}
-rm -f t/00signature.t
+%setup -q -n %{pdir}-%{pnam}-%{fver}
 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
 
 %build
@@ -83,14 +90,29 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc Changes README TODO
-%{perl_vendorlib}/Test/*.pm
+%doc Changes README
+%{perl_vendorlib}/ok.pm
 %{perl_vendorlib}/Test/Builder
-%{_mandir}/man3/*
+%{perl_vendorlib}/Test/Builder.pm
+%{perl_vendorlib}/Test/More.pm
+%{perl_vendorlib}/Test/Simple.pm
+%{perl_vendorlib}/Test/Tester
+%{perl_vendorlib}/Test/Tester.pm
+%{perl_vendorlib}/Test/use
+%{perl_vendorlib}/Test2.pm
+%{perl_vendorlib}/Test2
+%{_mandir}/man3/Test::Builder*.3pm*
+%{_mandir}/man3/Test::More.3pm*
+%{_mandir}/man3/Test::Simple.3pm*
+%{_mandir}/man3/Test::Tester*.3pm*
+%{_mandir}/man3/Test::Tutorial.3pm*
+%{_mandir}/man3/Test::use::ok.3pm*
+%{_mandir}/man3/Test2*.3pm*
+%{_mandir}/man3/ok.3pm*
This page took 0.090971 seconds and 4 git commands to generate.