]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blobdiff - perl-Test-Simple.spec
- BR: new rpm (new perl.prov), rel++
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
index a0a993553a979a6c16b09ea4843d2e81a6eb2472..d8029dbdb8c957fbb5f296578dd2151c30d1e0f4 100644 (file)
@@ -1,20 +1,45 @@
+#
+# Conditional build:
+# _without_tests - do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Test
-%define        pnam    Simple
-Summary:       Test::Simple perl module
-Summary(pl):   Modu³ perla Test::Simple
+%define                pdir    Test
+%define                pnam    Simple
+Summary:       Test::Simple Perl module
+Summary(cs):   Modul Test::Simple pro Perl
+Summary(da):   Perlmodul Test::Simple
+Summary(de):   Test::Simple Perl Modul
+Summary(es):   Módulo de Perl Test::Simple
+Summary(fr):   Module Perl Test::Simple
+Summary(it):   Modulo di Perl Test::Simple
+Summary(ja):   Test::Simple Perl ¥â¥¸¥å¡¼¥ë
+Summary(ko):   Test::Simple ÆÞ ¸ðÁÙ
+Summary(no):   Perlmodul Test::Simple
+Summary(pl):   Modu³ Perla Test::Simple
+Summary(pt):   Módulo de Perl Test::Simple
+Summary(pt_BR):        Módulo Perl Test::Simple
+Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl Test::Simple
+Summary(sv):   Test::Simple Perlmodul
+Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl Test::Simple
+Summary(zh_CN):        Test::Simple Perl Ä£¿é
 Name:          perl-%{pdir}-%{pnam}
-Version:       0.45
+Version:       0.47
 Release:       1
 License:       GPL
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
 BuildRequires: perl >= 5.6.1
-BuildRequires: perl(Test::Harness)
-BuildRequires: rpm-perlprov >= 3.0.3-16
+BuildRequires: rpm-perlprov >= 4.0.2-104
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# false requires found by rpm 4.0.2
+%if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
+%define                _noautoreq      'perl(threads)' 'perl(threads::shared)'
+%else
+Requires:      perl(threads) perl(threads::shared)
+%endif
+
 %description
 This is an extremely simple, extremely basic module for writing tests
 suitable for CPAN modules and other pursuits. If you wish to do more
@@ -30,9 +55,11 @@ test
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL
 %{__make}
 
+%{!?_without_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
@@ -44,5 +71,5 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Changes README TODO
-%{perl_sitelib}/Test
+%{perl_sitelib}/Test/*.pm
 %{_mandir}/man3/*
This page took 0.03566 seconds and 4 git commands to generate.