]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blobdiff - perl-Test-Simple.spec
- BR: new rpm (new perl.prov), rel++
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
index 9b1e3f19730ee666083446beeb5a401927ac1640..d8029dbdb8c957fbb5f296578dd2151c30d1e0f4 100644 (file)
@@ -1,43 +1,75 @@
-%define        pdir    Test
-%define        pnam    Simple
+#
+# Conditional build:
+# _without_tests - do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-Summary:       Test-Simple perl module
-Summary(pl):   Modu³ perla Test-Simple
+%define                pdir    Test
+%define                pnam    Simple
+Summary:       Test::Simple Perl module
+Summary(cs):   Modul Test::Simple pro Perl
+Summary(da):   Perlmodul Test::Simple
+Summary(de):   Test::Simple Perl Modul
+Summary(es):   Módulo de Perl Test::Simple
+Summary(fr):   Module Perl Test::Simple
+Summary(it):   Modulo di Perl Test::Simple
+Summary(ja):   Test::Simple Perl ¥â¥¸¥å¡¼¥ë
+Summary(ko):   Test::Simple ÆÞ ¸ðÁÙ
+Summary(no):   Perlmodul Test::Simple
+Summary(pl):   Modu³ Perla Test::Simple
+Summary(pt):   Módulo de Perl Test::Simple
+Summary(pt_BR):        Módulo Perl Test::Simple
+Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl Test::Simple
+Summary(sv):   Test::Simple Perlmodul
+Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl Test::Simple
+Summary(zh_CN):        Test::Simple Perl Ä£¿é
 Name:          perl-%{pdir}-%{pnam}
-Version:       0.41
+Version:       0.47
 Release:       1
 License:       GPL
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6
-BuildRequires: perl-Test-Harness
+BuildRequires: perl >= 5.6.1
+BuildRequires: rpm-perlprov >= 4.0.2-104
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# false requires found by rpm 4.0.2
+%if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
+%define                _noautoreq      'perl(threads)' 'perl(threads::shared)'
+%else
+Requires:      perl(threads) perl(threads::shared)
+%endif
+
 %description
+This is an extremely simple, extremely basic module for writing tests
+suitable for CPAN modules and other pursuits. If you wish to do more
+complicated testing, use the Test::More module (a drop-in replacement
+for this one).
 
 %description -l pl
+To jest bardzo prosty, bardzo podstawowy modu³ do pisania testów
+pasuj±cych do modu³ów CPAN i innych. Do bardziej skomplikowanych
+testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego ten).
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL
 %{__make}
 
+%{!?_without_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf Changes README TODO
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%{perl_sitelib}/Test
+%doc Changes README TODO
+%{perl_sitelib}/Test/*.pm
 %{_mandir}/man3/*
This page took 0.083203 seconds and 4 git commands to generate.