]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blobdiff - perl-Test-Simple.spec
- updated to 0.96
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
index c3b9445471b185c59549533efb49f3d278072980..8178ad6688b3254664856b009b378b6d77e1df01 100644 (file)
@@ -1,50 +1,91 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Test
-%define        pnam    Simple
-Summary:       Test-Simple perl module
-Summary(pl):   Modu³ perla Test-Simple
-Name:          perl-%{pdir}-%{pnam}
-Version:       0.41
-Release:       5
-License:       GPL
+%define                pdir    Test
+%define                pnam    Simple
+Summary:       Test::Simple - basic utilities for writing tests
+Summary(pl.UTF-8):     Test::Simple - podstawowe narzędzia do pisania testów
+Name:          perl-Test-Simple
+Version:       0.96
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6.1
-BuildRequires: perl-Test-Harness
+Source0:       http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWERN/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: fbc734a7bb5b3fc3e2bc706e19d08b26
+URL:           http://search.cpan.org/dist/Test-Simple/
+%{?with_tests:BuildRequires:   perl-Test-Harness >= 2.03}
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+Provides:      perl-Test-Builder-Tester = 1.20
+Obsoletes:     perl-Test-Builder-Tester = 0:1.01
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _noautoreq      'perl(threads)' 'perl(threads::shared)'
+
 %description
-This is an extremely simple, extremely basic module for writing tests
-suitable for CPAN modules and other pursuits. If you wish to do more
-complicated testing, use the Test::More module (a drop-in replacement
-for this one).
+AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
+me to Detroit, but don't make me write tests!
+   -- perldoc Test::Tutorial
+
+Test::Simple is an extremely simple, extremely basic module for
+writing tests suitable for CPAN modules and other pursuits. If you
+wish to do more complicated testing, use the Test::More module (a
+drop-in replacement for this one).
+
+The purpose of Test::More is to provide a wide range of testing
+utilities. Various ways to say "ok" with better diagnostics,
+facilities to skip tests, test future features and compare complicated
+data structures. While you can do almost anything with a simple "ok()"
+function, it doesn't provide good diagnostic output.
 
-%description -l pl
-To jest bardzo prosty, bardzo podstawowy modu³ do pisania testów
-pasuj±cych do modu³ów CPAN i innych. Do bardziej skomplikowanych
-testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego ten).
+%description -l pl.UTF-8
+AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
+mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
+testów!
+   -- perldoc Test::Tutorial
+
+Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
+pisania testów pasujących do modułów CPAN i innych. Do bardziej
+skomplikowanych testów lepiej używać modułu Test::More (zastępującego
+ten).
+
+Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
+testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
+ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
+porównywaniu skomplikowanych struktur danych. O ile można zrobić
+prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
+diagnostycznego.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
+rm -f t/00signature.t
+%{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf Changes README TODO
+rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%{perl_sitelib}/Test
-%{_mandir}/man3/*
+%doc Changes README TODO
+%{perl_vendorlib}/Test/*.pm
+%{perl_vendorlib}/Test/Builder
+%{_mandir}/man3/Test::*.3pm*
This page took 0.28258 seconds and 4 git commands to generate.