]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- new bconds
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple Perl module
9 Summary(cs):    Modul Test::Simple pro Perl
10 Summary(da):    Perlmodul Test::Simple
11 Summary(de):    Test::Simple Perl Modul
12 Summary(es):    Módulo de Perl Test::Simple
13 Summary(fr):    Module Perl Test::Simple
14 Summary(it):    Modulo di Perl Test::Simple
15 Summary(ja):    Test::Simple Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    Test::Simple ÆÞ ¸ðÁÙ
17 Summary(nb):    Perlmodul Test::Simple
18 Summary(pl):    Modu³ Perla Test::Simple
19 Summary(pt):    Módulo de Perl Test::Simple
20 Summary(pt_BR): Módulo Perl Test::Simple
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl Test::Simple
22 Summary(sv):    Test::Simple Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl Test::Simple
24 Summary(zh_CN): Test::Simple Perl Ä£¿é
25 Name:           perl-%{pdir}-%{pnam}
26 Version:        0.47
27 Release:        2
28 License:        GPL
29 Group:          Development/Languages/Perl
30 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
31 # Source0-md5: 4a6c12685bfeadfe8ff6fca70825f90c
32 BuildRequires:  perl-devel >= 5.6.1
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # false requires found by rpm 4.0.2
38 %if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
39 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
40 %else
41 Requires:       perl(threads) perl(threads::shared)
42 %endif
43
44 %description
45 This is an extremely simple, extremely basic module for writing tests
46 suitable for CPAN modules and other pursuits. If you wish to do more
47 complicated testing, use the Test::More module (a drop-in replacement
48 for this one).
49
50 %description -l pl
51 To jest bardzo prosty, bardzo podstawowy modu³ do pisania testów
52 pasuj±cych do modu³ów CPAN i innych. Do bardziej skomplikowanych
53 testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego ten).
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes README TODO
77 %{perl_vendorlib}/Test/*.pm
78 %{_mandir}/man3/*
This page took 0.069848 seconds and 4 git commands to generate.