]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- updated to 1.302140
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl.UTF-8):      Test::Simple - podstawowe narzędzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        1.302140
12 %define fver    %(echo %{version} | tr -d _)
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
18 # Source0-md5:  2a3eba9fbafe80a24ce75b604ab045f1
19 URL:            https://metacpan.org/release/Test-Simple
20 %{?with_tests:BuildRequires:    perl-Test-Harness >= 2.03}
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 # see lib/Test/Builder/Tester.pm /VERSION
24 Provides:       perl-Test-Builder-Tester = %{version}
25 # see lib/Test/Tester.pm /VERSION
26 Provides:       perl-Test-Tester = %{version}
27 # see lib/Test/use/ok.pm /VERSION
28 Provides:       perl-Test-use-ok = %{version}
29 # obsolete only versions up to last standalone release to avoid obsoleting perl-modules
30 # Test::Builder::Tester 1.01
31 # Test::Tester 0.109
32 # Test::use::ok 0.11
33 Obsoletes:      perl-Test-Builder-Tester < 1.02
34 Obsoletes:      perl-Test-Tester < 0.110
35 Obsoletes:      perl-Test-use-ok < 0.12
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
40
41 %description
42 AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
43 me to Detroit, but don't make me write tests!
44    -- perldoc Test::Tutorial
45
46 Test::Simple is an extremely simple, extremely basic module for
47 writing tests suitable for CPAN modules and other pursuits. If you
48 wish to do more complicated testing, use the Test::More module (a
49 drop-in replacement for this one).
50
51 The purpose of Test::More is to provide a wide range of testing
52 utilities. Various ways to say "ok" with better diagnostics,
53 facilities to skip tests, test future features and compare complicated
54 data structures. While you can do almost anything with a simple "ok()"
55 function, it doesn't provide good diagnostic output.
56
57 %description -l pl.UTF-8
58 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
59 mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
60 testów!
61    -- perldoc Test::Tutorial
62
63 Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
64 pisania testów pasujących do modułów CPAN i innych. Do bardziej
65 skomplikowanych testów lepiej używać modułu Test::More (zastępującego
66 ten).
67
68 Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
69 testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
70 ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
71 porównywaniu skomplikowanych struktur danych. O ile można zrobić
72 prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
73 diagnostycznego.
74
75 %prep
76 %setup -q -n %{pdir}-%{pnam}-%{fver}
77 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
78
79 %build
80 %{__perl} Makefile.PL \
81         INSTALLDIRS=vendor
82 %{__make}
83
84 %{?with_tests:%{__make} test}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc Changes README
100 %{perl_vendorlib}/ok.pm
101 %{perl_vendorlib}/Test/Builder
102 %{perl_vendorlib}/Test/Builder.pm
103 %{perl_vendorlib}/Test/More.pm
104 %{perl_vendorlib}/Test/Simple.pm
105 %{perl_vendorlib}/Test/Tester
106 %{perl_vendorlib}/Test/Tester.pm
107 %{perl_vendorlib}/Test/use
108 %{perl_vendorlib}/Test2.pm
109 %{perl_vendorlib}/Test2
110 %{_mandir}/man3/Test::Builder*.3pm*
111 %{_mandir}/man3/Test::More.3pm*
112 %{_mandir}/man3/Test::Simple.3pm*
113 %{_mandir}/man3/Test::Tester*.3pm*
114 %{_mandir}/man3/Test::Tutorial.3pm*
115 %{_mandir}/man3/Test::use::ok.3pm*
116 %{_mandir}/man3/Test2*.3pm*
117 %{_mandir}/man3/ok.3pm*
This page took 0.06242 seconds and 4 git commands to generate.