]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- version 0.51
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl):    Test::Simple - podstawowe narzêdzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        0.51
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b93ab775277752627b8c20ef5e2b5a52
18 URL:            http://search.cpan.org/dist/Test-Simple/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # false requires found by rpm 4.0.2
25 %if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
26 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
27 %else
28 Requires:       perl(threads) perl(threads::shared)
29 %endif
30
31 %description
32 AHHHHHHH!!!!  NOT TESTING!  Anything but testing!  Beat me, whip me,
33 send me to Detroit, but don't make me write tests!
34         -- perldoc Test::Tutorial
35
36 Test::Simple is an extremely simple, extremely basic module for
37 writing tests suitable for CPAN modules and other pursuits. If you
38 wish to do more complicated testing, use the Test::More module (a
39 drop-in replacement for this one).
40
41 The purpose of Test::More is to provide a wide range of testing
42 utilities. Various ways to say "ok" with better diagnostics,
43 facilities to skip tests, test future features and compare complicated
44 data structures. While you can do almost anything with a simple "ok()"
45 function, it doesn't provide good diagnostic output.
46
47 %description -l pl
48 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie mnie,
49 biczujcie mnie, wy¶lijcie do Detroit, ale nie ka¿cie pisaæ testów!
50         -- perldoc Test::Tutorial
51
52 Test::Simple jest bardzo prostym, bardzo podstawowym modu³em do
53 pisania testów pasuj±cych do modu³ów CPAN i innych. Do bardziej
54 skomplikowanych testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego
55 ten).
56
57 Celem Test::More jest dostarczenie szerokiego zakresu narzêdzi do
58 testowania. Ró¿ne sposoby powiedzenia "ok" z lepsz± diagnostyk±,
59 u³atwienia przy pomijaniu testów, testowaniu przysz³ych mo¿liwo¶ci
60 i porównywaniu skomplikowanych struktur danych. O ile mo¿na zrobiæ
61 prawie wszystko prost± funkcj± "ok()", nie daje ona dobrego wyj¶cia
62 diagnostycznego.
63
64 %prep
65 %setup -q -n %{pdir}-%{pnam}-%{version}
66 rm -f t/00signature.t
67 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
68
69 %build
70 %{__perl} Makefile.PL \
71         INSTALLDIRS=vendor
72 %{__make}
73
74 %{?with_tests:%{__make} test}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc Changes README TODO
88 %{perl_vendorlib}/Test/*.pm
89 %{_mandir}/man3/*
This page took 0.039469 seconds and 4 git commands to generate.