]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- cosmetics (spaces -> tabs)
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    Simple
8 Summary:        Test::Simple Perl module
9 Summary(cs):    Modul Test::Simple pro Perl
10 Summary(da):    Perlmodul Test::Simple
11 Summary(de):    Test::Simple Perl Modul
12 Summary(es):    Módulo de Perl Test::Simple
13 Summary(fr):    Module Perl Test::Simple
14 Summary(it):    Modulo di Perl Test::Simple
15 Summary(ja):    Test::Simple Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    Test::Simple ÆÞ ¸ðÁÙ
17 Summary(nb):    Perlmodul Test::Simple
18 Summary(pl):    Modu³ Perla Test::Simple
19 Summary(pt):    Módulo de Perl Test::Simple
20 Summary(pt_BR): Módulo Perl Test::Simple
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl Test::Simple
22 Summary(sv):    Test::Simple Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl Test::Simple
24 Summary(zh_CN): Test::Simple Perl Ä£¿é
25 Name:           perl-Test-Simple
26 Version:        0.47
27 Release:        3
28 # same as perl
29 License:        GPL v1+ or Artistic
30 Group:          Development/Languages/Perl
31 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
32 # Source0-md5:  4a6c12685bfeadfe8ff6fca70825f90c
33 BuildRequires:  perl-devel >= 1:5.8.0
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 # false requires found by rpm 4.0.2
39 %if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
40 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
41 %else
42 Requires:       perl(threads) perl(threads::shared)
43 %endif
44
45 %description
46 This is an extremely simple, extremely basic module for writing tests
47 suitable for CPAN modules and other pursuits. If you wish to do more
48 complicated testing, use the Test::More module (a drop-in replacement
49 for this one).
50
51 %description -l pl
52 To jest bardzo prosty, bardzo podstawowy modu³ do pisania testów
53 pasuj±cych do modu³ów CPAN i innych. Do bardziej skomplikowanych
54 testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego ten).
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make}
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README TODO
78 %{perl_vendorlib}/Test/*.pm
79 %{_mandir}/man3/*
This page took 0.060129 seconds and 4 git commands to generate.