]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- O: perl-Test-Builder-Tester = 1.01
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl):    Test::Simple - podstawowe narzêdzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        0.64
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e22dcd4f06eed7b389f2bd0d17ed4dc1
18 URL:            http://search.cpan.org/dist/Test-Simple/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Provides:       perl-Test-Builder-Tester = 1.04
22 Obsoletes:      perl-Test-Builder-Tester = 0:1.01
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # false requires found by rpm 4.0.2
27 %if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
28 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
29 %else
30 Requires:       perl(threads) perl(threads::shared)
31 %endif
32
33 %description
34 AHHHHHHH!!!!  NOT TESTING!  Anything but testing!  Beat me, whip me,
35 send me to Detroit, but don't make me write tests!
36         -- perldoc Test::Tutorial
37
38 Test::Simple is an extremely simple, extremely basic module for
39 writing tests suitable for CPAN modules and other pursuits. If you
40 wish to do more complicated testing, use the Test::More module (a
41 drop-in replacement for this one).
42
43 The purpose of Test::More is to provide a wide range of testing
44 utilities. Various ways to say "ok" with better diagnostics,
45 facilities to skip tests, test future features and compare complicated
46 data structures. While you can do almost anything with a simple "ok()"
47 function, it doesn't provide good diagnostic output.
48
49 %description -l pl
50 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie mnie,
51 biczujcie mnie, wy¶lijcie do Detroit, ale nie ka¿cie pisaæ testów!
52         -- perldoc Test::Tutorial
53
54 Test::Simple jest bardzo prostym, bardzo podstawowym modu³em do
55 pisania testów pasuj±cych do modu³ów CPAN i innych. Do bardziej
56 skomplikowanych testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego
57 ten).
58
59 Celem Test::More jest dostarczenie szerokiego zakresu narzêdzi do
60 testowania. Ró¿ne sposoby powiedzenia "ok" z lepsz± diagnostyk±,
61 u³atwienia przy pomijaniu testów, testowaniu przysz³ych mo¿liwo¶ci
62 i porównywaniu skomplikowanych struktur danych. O ile mo¿na zrobiæ
63 prawie wszystko prost± funkcj± "ok()", nie daje ona dobrego wyj¶cia
64 diagnostycznego.
65
66 %prep
67 %setup -q -n %{pdir}-%{pnam}-%{version}
68 rm -f t/00signature.t
69 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
70
71 %build
72 %{__perl} Makefile.PL \
73         INSTALLDIRS=vendor
74 %{__make}
75
76 %{?with_tests:%{__make} test}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc Changes README TODO
90 %{perl_vendorlib}/Test/*.pm
91 %{perl_vendorlib}/Test/Builder
92 %{_mandir}/man3/*
This page took 0.034999 seconds and 4 git commands to generate.