]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- release 1, Provides: perl-Test-Builder-Tester
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl):    Test::Simple - podstawowe narzêdzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        0.64
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e22dcd4f06eed7b389f2bd0d17ed4dc1
18 URL:            http://search.cpan.org/dist/Test-Simple/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Provides:       perl-Test-Builder-Tester = 1.04
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # false requires found by rpm 4.0.2
26 %if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
27 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
28 %else
29 Requires:       perl(threads) perl(threads::shared)
30 %endif
31
32 %description
33 AHHHHHHH!!!!  NOT TESTING!  Anything but testing!  Beat me, whip me,
34 send me to Detroit, but don't make me write tests!
35         -- perldoc Test::Tutorial
36
37 Test::Simple is an extremely simple, extremely basic module for
38 writing tests suitable for CPAN modules and other pursuits. If you
39 wish to do more complicated testing, use the Test::More module (a
40 drop-in replacement for this one).
41
42 The purpose of Test::More is to provide a wide range of testing
43 utilities. Various ways to say "ok" with better diagnostics,
44 facilities to skip tests, test future features and compare complicated
45 data structures. While you can do almost anything with a simple "ok()"
46 function, it doesn't provide good diagnostic output.
47
48 %description -l pl
49 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie mnie,
50 biczujcie mnie, wy¶lijcie do Detroit, ale nie ka¿cie pisaæ testów!
51         -- perldoc Test::Tutorial
52
53 Test::Simple jest bardzo prostym, bardzo podstawowym modu³em do
54 pisania testów pasuj±cych do modu³ów CPAN i innych. Do bardziej
55 skomplikowanych testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego
56 ten).
57
58 Celem Test::More jest dostarczenie szerokiego zakresu narzêdzi do
59 testowania. Ró¿ne sposoby powiedzenia "ok" z lepsz± diagnostyk±,
60 u³atwienia przy pomijaniu testów, testowaniu przysz³ych mo¿liwo¶ci
61 i porównywaniu skomplikowanych struktur danych. O ile mo¿na zrobiæ
62 prawie wszystko prost± funkcj± "ok()", nie daje ona dobrego wyj¶cia
63 diagnostycznego.
64
65 %prep
66 %setup -q -n %{pdir}-%{pnam}-%{version}
67 rm -f t/00signature.t
68 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
69
70 %build
71 %{__perl} Makefile.PL \
72         INSTALLDIRS=vendor
73 %{__make}
74
75 %{?with_tests:%{__make} test}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes README TODO
89 %{perl_vendorlib}/Test/*.pm
90 %{perl_vendorlib}/Test/Builder
91 %{_mandir}/man3/*
This page took 0.038839 seconds and 4 git commands to generate.