]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- use the __perl macro
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple Perl module
9 Summary(cs):    Modul Test::Simple pro Perl
10 Summary(da):    Perlmodul Test::Simple
11 Summary(de):    Test::Simple Perl Modul
12 Summary(es):    Módulo de Perl Test::Simple
13 Summary(fr):    Module Perl Test::Simple
14 Summary(it):    Modulo di Perl Test::Simple
15 Summary(ja):    Test::Simple Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    Test::Simple ÆÞ ¸ðÁÙ
17 Summary(no):    Perlmodul Test::Simple
18 Summary(pl):    Modu³ Perla Test::Simple
19 Summary(pt):    Módulo de Perl Test::Simple
20 Summary(pt_BR): Módulo Perl Test::Simple
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl Test::Simple
22 Summary(sv):    Test::Simple Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl Test::Simple
24 Summary(zh_CN): Test::Simple Perl Ä£¿é
25 Name:           perl-%{pdir}-%{pnam}
26 Version:        0.47
27 Release:        1
28 License:        GPL
29 Group:          Development/Languages/Perl
30 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
31 BuildRequires:  perl >= 5.6.1
32 BuildRequires:  rpm-perlprov >= 3.0.3-16
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # false requires found by rpm 4.0.2
37 %if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
38 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
39 %else
40 Requires:       perl(threads) perl(threads::shared)
41 %endif
42
43 %description
44 This is an extremely simple, extremely basic module for writing tests
45 suitable for CPAN modules and other pursuits. If you wish to do more
46 complicated testing, use the Test::More module (a drop-in replacement
47 for this one).
48
49 %description -l pl
50 To jest bardzo prosty, bardzo podstawowy modu³ do pisania testów
51 pasuj±cych do modu³ów CPAN i innych. Do bardziej skomplikowanych
52 testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego ten).
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL
59 %{__make}
60
61 %{!?_without_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README TODO
74 %{perl_sitelib}/Test/*.pm
75 %{_mandir}/man3/*
This page took 0.045722 seconds and 4 git commands to generate.